1 2 Previous Next 23 Replies Latest reply on Jul 4, 2017 7:21 PM by Stephen Huston

    Stop pasting formatted text by default.

    peteraddison

      It seems odd to me, that I can't find any discussion on this but here goes:

       

      I dislike that Filemaker by default pastes formatted text that carries on into every related layout. Almost invariable when someone copies information from another program such as word or a browser, the wrong formatting is carried into every place the text is used almost invariably with undesirable results. Instead of picking up the default formatting in another layout, the (usually bad) formatting from the original web page or whatever is showing up.

       

      Why is this the default? Can I turn it off?

       

      I know I can hit ctrl-z to unformed but this is a pain in the butt to try and remember AND an uneccessary extra step. Especially if dragging and dropping; a wonderful feature made useless by the auto-format default.

       

      ( A lot of times you can't tell that the text you pasted is in the wrong format until it starts showing up and destroying your carefully crafted forms and screens. This is when I start to really scream at Filemaker.)

        • 1. Re: Stop pasting formatted text bye default.
          jbrown

          Howdy.

           

          TEXT THIS FORMATTING

           

          I copied that from MS Word into this reply box. The formatting stayed the same. Is that a fault of the browser I'm in? Excel took the red bold formatting as well when I copied from Word into Excel.

           

          I'm not sure its a default setting, and I'm not sure its a fault of FileMaker. The formatting is part of the text, right? So if you copy and paste, wouldn't the formatting naturally go into the field?

           

          it seems the formatting of the text copied into a field overrides the formatting of the field itself. That seems to make sense.

           

          Solutions:

          You could set up every field that is enterable to be an auto-enter replace contents by using the function TextFormatRemove (YOUR FIELD).  This would remove any formatting that is copied into the field.

           

          OR

          You could run a script on the form when they close the form to remove all formatting on every field in that layout. That's pretty easy to do. There's a function that gets a list of the fields on the layout. you could then loop through the fields and remove the formatting on the text for that record.

           

          I very often warn my users that their ugly formatting will show up and train them not to copy and paste. But if they do, in, say a data entry form, you could do as I suggest above.

           

          Would any of those prevent you from screaming at FileMaker?

          • 2. Re: Stop pasting formatted text by default.
            peteraddison

            No, it doesn't make sense, to me, to retain the formatting from one application to another application where you are probably using the information for a completely different purpose.

             

            For instance, on a web page, you may want 14 pt Times Roman in Yellow in your address to match your web page; you certainly don't want it to look that way when you're addressing an invoice, you want it to match the rest of your invoice!

             

            I know I can script the field to remove the formatting, but why should I need to do that on *every *single *field where a person is likely to drop text. Plus, I don't want to strip it out of every field when I want the user to be able to add formatting. I just want to turn it of.

             

            your comment "I train them not to copy and paste" is a case in point. I WANT my users to have the convenience and accuracy of copy and paste, but not the headache of futzing around with incorrect local formatting.

            • 3. Re: Stop pasting formatted text by default.
              jbrown

              I get that it is frustrating for your users and for you. I guess I hadn't thought of the frustration level much.

               

              Since FIleMaker allows for styles, colors, and sizes for individual text in a field, I assume that means it allows for those things to be carried into a field from another application. That's the best answer I can give.

               

              At the moment, I cannot find any place to turn off that formatting-capture ability of a field. The only way I know of is to re-enter it using the auto-enter feature.

               

              I hope someone can shed light on this. Now I'm curious about it.

               

              EDIT: Could you use this  trick?

              How to Automate ‘Paste and Match Style’ in FileMaker | HomeBase Software

               

              Paste Text Only is an option in the edit menu. Maybe try that?

              • 4. Re: Stop pasting formatted text by default.
                peteraddison

                Hi Jeremy, thanks for the research. Those are three work arounds to the problem. But not a solution to the problem itself. I would have to enter calculation for the one issue, on every single field, and that eliminates the ability to use any formatting on the text in that field, ever.

                 

                The second and third solutions mean that the user has to use a menu item instead of keyboard short cut and remember to use a different command in both cases. (making Filemaker different from the entire rest of BOTH operating systems.) Plus, they don't work with drag and drop functionality, you have to remember to hit ctrl-z afterwards, another extra step.

                 

                (So no, I won't stop yelling at Filemaker until I get the option to turn it off either globally for a file or by client preferences.)

                • 5. Re: Stop pasting formatted text by default.
                  CarlSchwarz

                  You could also create a single script trigger to remove the text formatting, then you have one script that captures the "paste" key combination and just select all your fields at once on the layout and add the trigger - so not too much work to add it.

                   

                  TextFormatRemove( get(activefieldcontents) )

                   

                  I do remove the formatting for address book entries where it's highly likely for the user to copy-paste names and addresses out of a web browser and it's highly desirable to have a consistent look&feel when searching/printing etc.

                  • 6. Re: Stop pasting formatted text by default.
                    bigtom

                    I was thinking about posting about this same problem as I thought I was not seeing some setting to get this right.

                     

                    This is something I struggle with on a daily basis and I have messed with all the formatting options in the inspector. Syncronize with Field's Font is obviously not really for this even though it may appear so. There should be a field entry option to strip all formatting and format to the field settings. It makes myself and the users angry. They need to copy things then paste into an intermediate application that strips the formatting and then copy from there to paste into FM.

                     

                    One way I have used to get around this are calculated fields, but those are costly and really are duplicating data.

                    • 7. Re: Stop pasting formatted text by default.
                      peteraddison

                      bigtom, see Jeremy's answers for some better work-arounds, particularly this link:

                       

                      How to Automate ‘Paste and Match Style’ in FileMaker | HomeBase Software

                       

                      Carl's workaround is good, you could create a trigger script, but it's complesx.


                      The problem is that these are all workarounds that should have a setting somewhere, even if it's at the layout level! There's not enough control over this very controversial default.

                      • 8. Re: Stop pasting formatted text by default.
                        bigtom

                        CarlSchwarz wrote:

                         

                        TextFormatRemove( get(activefieldcontents) )

                         

                        I do remove the formatting for address book entries where it's highly likely for the user to copy-paste names and addresses out of a web browser and it's highly desirable to have a consistent look&feel when searching/printing etc.

                        Does this set the text to a default font or the font defined in the field? I do not like the idea of having extra scripts running, but if it solves the problem well enough might not be the thing to do. The main issue I have with this is sometimes addresses or other data needs to be copied from and email or web because it falls outside of the standard import rules and was not automatically entered. The copied text does not work on printouts and is sometimes so small it is not readable.

                        • 9. Re: Stop pasting formatted text by default.
                          CarlSchwarz

                          It removes formatting the stored formatting so it's the font defined in whatever field is displaying it rather than the stored font with the data.  E.g. your data entry formatting is probably small, and your printing formatting is probably large, it will follow that formatting.

                           

                          A script trigger is a quick way to do it but capturing user keypresses to capture the paste keypress on networked solutions can be slow.  A calculation is probably better in that case.

                           

                          What I ACTUALLY do is I have used custom menu's and taken over the PASTE command in the menu   That works awesome.

                          • 10. Re: Stop pasting formatted text by default.
                            siplus

                            you also have this:

                             

                            Screen Shot 2016-03-03 at 07.46.34.png

                            • 11. Re: Stop pasting formatted text by default.
                              gdurniak

                              I just got hit with this myself:  an office that loves to copy / paste

                               

                              I see three Feature Requests here:

                               

                              - make "remove text formatting" an option in a field definition

                               

                              - make "remove text formatting" an option for a field on a layout  ( e.g. display without format )

                               

                              - make "remove text formatting" an option for Conditional Formatting ( you can currently add a format, but not remove one )

                               

                              greg

                               

                              > Why is this the default? Can I turn it off?

                              • 12. Re: Stop pasting formatted text by default.
                                schamblee

                                The method I use is similar to what has been mention above.

                                 

                                Create a Auto-Enter Calculation field with TextFormatRemove ( Self ) as the calculation then uncheck do not replace existing value.

                                • 13. Re: Stop pasting formatted text by default.
                                  hbrendel

                                  In all my solutions I change the 'Paste' menu option to 'Paste without style' in a custom menu. Sometimes it's the only thing I change in the menu, but most of the times my solution has a completely different custom menu.

                                  Once the menu option is changed, Ctrl/Cmd-V will paste without style.

                                   

                                  BTW I totally agree with you. Raw data in tables should not contain any formatting. Formatting is done on the layout for displaying purposes.

                                  2 of 2 people found this helpful
                                  • 14. Re: Stop pasting formatted text by default.
                                    cbishop

                                    I've tried this method too - overwriting the default menu set.  However, this makes development a pain because standard paste hotkey doesn't work in Script Editor and other areas.  Also, in all web viewers and custom dialog boxes, paste doesn't work if you do this.

                                     

                                    I though I remembered a preference in older versions of FileMaker for pasting with styling or not, or using formatted text in general.  Anybody else remember this, and if so, maybe there's still that hidden preference we could set in the preferences plist / registry?

                                    1 2 Previous Next