3 Replies Latest reply on May 13, 2016 2:42 AM by user9826

    Fatal error at Script Workspace

    user9826

      Product and version FileMaker Pro 14.0.5

      OS and version: Windows 10 Professional

      Browser and version

      Hardware: Desktop Windows system

      Description: Fatal error at Scripting Workspace

      How to replicate

      Workaround (if any)

       

      Using Script Workspace gives at certain times critical errors at Filemaker Pro and Advanced.

      We discovered that it happens at the IF statment, when the formula is bigger than fits in 1 line.

      Specially when fields are used in the formula, coming from External data sources.

      Here it happens at all IF statements, when using ODBC fields, but only when the formula is to big to show it at once.

       

      The error passes by when moving the mouse above the formula, when it must open a box with the complete formula in it.

      Moving the mouse directly to the change button, this will work fine.

       

      Hope you can solve this.

      The critical errors had been damaged several databases...

      We love to backup!

       

      Yours,

      Wim Lagerweij,

      EEnvoudigg.nl

        • 1. Re: Fatal error at Script Workspace
          TSGal

          user9826:

           

          Thank you for your post.

           

          Currently, I do not have access to a ESS table.  I have been unsuccessful trying to replicate the issue using a related field in the Calculation formula.  Regardless, I have sent your post to our Development and Testing departments for review.  When I receive any feedback, I will let you know.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Fatal error at Script Workspace
            TSGal

            user9826:

             

            Our Testing department could not reproduce the issue using MySQL.  Testing would like to know the ODBC data source and the ODBC driver and version being used.  In addition, what is the field type being referenced in the ODBC source.  Also, did this work previously with Windows 10 or a previous version?

             

            TSGal

            FileMaker, Inc.

            • 3. Re: Fatal error at Script Workspace
              user9826

              Hi,

               

              Sorry for the delay of my reply.

               

              I tested it with FM Pro 15 this week and it looks to be solved right now.

              Still, version 14 still gives hard errors.

               

              But with the renewal of 15, it is solved for me.

               

              Thanks for your reply, TSGal.