8 Replies Latest reply on Mar 13, 2016 10:57 AM by wimdecorte

    Script Engine

    Mariano Bosco

      hello to all, has anyone had problems with the Script Engine and found a solution?

        • 1. Re: Script Engine
          coherentkris

          How about asking a specific question?

          What are you experiencing, when are you experiencing it, and what do you expect to experience that your not?

          This isn't a Zen Koan solving forum.

          • 2. Re: Script Engine
            monkeybreadsoftware

            Yes, I once had the problem that I could not search for script steps.

            So I modified the script editor by writing some plugins functions. :-)

            • 3. Re: Script Engine
              Draco

              Yes,..

              Some scripts that worked in FM13, in FM14 not work. Send the error FM Inc. along with the files and never had response, Fm14v5 not work, ... solve it with ExecuteSQL.

               

              Draco

              • 4. Re: Script Engine
                wimdecorte

                can you be a bit more specific: what exactly did not work, what steps?

                • 5. Re: Script Engine
                  wimdecorte

                  To give you an example: just last week I I was working on a system that is currently in 12 and they were considering to go to 14.

                  One script that opens a new window, blanks out a field then goes to another field to open the value list.  Works in 12, did not appear to work in 14: the value list would not open, the proper field would not activate.

                   

                  Turns out that there is a bug in 12 where the "go to field" would fail and act as an implicit commit that you can get from an empty "go to field" instruction.

                  In 14 the go to field did not fail so the behaviour was slightly different but easy to fix the script to get the intended behaviour.

                  • 6. Re: Script Engine
                    Draco

                    Win, this was the mistake ... the script works perfect FM13, ... in FM14 ... NO.

                     

                    correction : in FM14v5  It has been solved.

                     

                    the error was. before fm14v5

                    error before FM14v5

                     

                     

                    regards

                    Draco

                    • 7. Re: Script Engine
                      Mariano Bosco

                      Sorry for the unclear explanation, I describe the situation:

                      1 Filemaker Server 13v10, 20 Client (v.13, v14), SO Windows Server 2012 R2 Standard Edition.

                       

                      From about 15 clients I added a script that allows me to make a phone call via a Web Services. This script I do run from FMS via "Run script on Server". Using a plugin that allows me to make calls Web Servers "BASE ELEMENTS", installed on the server. Everything works perfectly but after some time, about 1 hour does not work anymore, I noticed through the activities of the server machine management "FileMaker Script Engine" is closed and consequently do not work with the script running as a server, After the command "fmsadmin RESTART FMSE - Y" works again....Have you ever?

                       

                      This is the error message:

                       

                      FileMaker Server 13.0v10 on FMS13 reported the following event:

                      016-03-09 15:09:38.496 +0100  Error      701         FMS13  FileMaker Script Engine process has terminated abnormally.

                       

                       

                      • 8. Re: Script Engine
                        wimdecorte

                        It's not clear to me how you can make a phone call through PSoS...

                         

                        Regardless of that: there seem to be some known issues with running plugins on FMS and it killing the FileMaker Server Script Engine (FMSE).

                         

                        So one approach is to restart the script engine from time to time through an OS schedule using the command line you know.

                         

                        As to the underlying cause: hard to say, check the event logs, look for clues, see if you can modify your script etc.