velistar

How can I redirect webviewer within WebDirect?

Discussion created by velistar on Mar 12, 2016
Latest reply on Sep 6, 2016 by beverly

Hi all,

 

I have implemented a custom html within Webviewer in a solution that shows a clickable image. Clicking on the webviewer uses the FMP Protocol and JS command "window.location.href" to trigger a script and move to another layout. Everything works fine in FMP and FMG. I see the webviewer just fine in WD but when I click obviously it triggers the FMP protocol and opens up FMP. I tried to use instead to redirect to "https://<domain>/fmi/webd#<dbname>?script=<myScript>&param=<param>" and this fails. It doesn't even load webviewer at all completely blank.

 

I remembered that WD uses iframes so looking up online I found that maybe using "window.top.location.href" would do the trick. This didn't work either but I tried to keep a simple url instead "www.google.com". This does indeed work when I click on the webviewer. The same goes with just using my domain name as well. The problem starts when I start going beyond the domain level and add "/fmi/...", which breaks webviewer.

 

Has anyone come across this? Is there a better way for webviewer to interact with the rest of the solution in WebDirect?

 

Thanks

Outcomes