AnsweredAssumed Answered

WebDirect Popover that wont close?

Question asked by RayGerman on Apr 6, 2016
Latest reply on Apr 7, 2016 by RayGerman

Hello Everyone,

 

I am very basic Filemaker user and am finding there are a many different ways to accomplish a goal in Filemaker. I am currently building a webdirect database solution to track our IT department hardware and software. My intent is to publish this in webdirect from our Filemaker Server. Unfortunately, I am stuck on this issue and cant seem to find a solution.

 

In a nutshell I have created a drop-down list that shows the values of a field called AssetType. I tested this in WebDirect and it worked as expected the drop-down list opened and showed all of the values in that field. I then found that there is no way for an end user to edit a drop-down list in webdirect.

 

So, I thought I have a solution...

 

I created

A new field and called it NewTypeEnter

I then added a pop-over button (With a + symbol icon) right next to AssetType

Using the field picker I added the NewType field to the pop-over

I then added a button in the pop-over below the NewTypeEnter filed and called it Add

 

Popover_issue.png

 

I assigned a script to the button as a Button Action

 

Button Action.png

 

I then added this script

Script.png

 

I then tested in Filemaker and it worked perfectly.

When I hit the + icon the pop-over opened.

I then entered a value in the field NewTypeEnter.

When I hit add, it copied that value and pasted it into the AssetType field

It then cleared the NewTypeEnter Field and closed the pop-over.

 

At this point, I'm thinking... That wasn't so bad... good solution it worked!  That was until I put the database in WebDirect.

In WebDirect everything works except the final step  "Close Popover"

 

I tried about 15 other methods yet for some reason that pop-over refuses to close in WebDirect. To make matters worse... That pop over remains open no matter what layout I go to...  Its like a zombie that follows me everywhere!!

 

I am running FM Server version 14.0.4.412 which I think is the latest....

 

Does anyone know if this is a know issue? Seems like a bug to me.... Any input would be appreciated. I am stuck at this point.

zombiePopover.png

 

Thanks,

Ray

Outcomes