2 Replies Latest reply on Apr 15, 2016 1:07 AM by Polarpro

    Syncronisation FM - MySql and "Commit Record"

    Polarpro

      Hello,

       

      I've come across a strange behavior when syncing an FM database with a MySql database:

       

      A script looks every few minutes in a FileMaker table called "FM_Jobs" for new records. If there are new records in this table, the script creates in an ESS table called "MySql_Jobs" the same records, through a relationship that allows the creation of new records. Each record contains about 20 fields that need to be set in the MySql table.

       

      For example, if there are eight new records, the script loops through these eight records. Within each loop there are several "Set field" script steps, and each loop finishes with a "Commit record" script step.

       

      This script has worked properly thousands of times, until lately. I found out that it was a certain new record that caused FileMaker to crash, when the script reached the "Commit record" step. I tried it several times; as soon as FileMaker tried to save the record in the MySql table, it crashed.

       

      I assumed that one of the FileMaker fields contained a value that MySql wouldn't accept (e.g. an incorrect timestamp), but couldn't find anything. So, I placed a "Commit record" step after each "Set field" step, to see where exactly the error would appear. But now, to my amazement, everything worked fine; no crash.

       

      So, it seems to me that somehow the script had problems with setting several fields "at once", but not with setting single fields.

       

      Has anybody a clue what the reason for this behavior could be?

       

      Thanks a lot,

      Mike