AnsweredAssumed Answered

Date Field Showing "?"

Question asked by disabled_morkus on Apr 14, 2016
Latest reply on Apr 15, 2016 by beverly

I have a date field that gets calculated with a date in the future based on the date a user enters in another field.

 

What's happening is that if I clear the initial date field, the calculated date field shows the nasty, but possibly expected, "?".

 

Using the data viewer the initial date field "isBlank" is true.

 

So, I tried to have an auto-enter calculation that would do an "IF" statement that if the initial field is blank, then just enter a "" in the calculated date field (clear it) or if the first date field is not blank, then go ahead and do the date calculation. Doesn't work.

 

I still get the "?" in the second, calculated date field, until I actually enter a date in the first date field. I also grew the field to make sure the date, or whatever was in the "?" date field wasn't taking up too much space to display (nope).

 

--

 

What's weird is that on new records, before I enter a date in the first field, the calculated date field is nice and blank (no "?").

 

--

 

So, how do I handle this situation so the "?" does not appear in the calculated date field?

 

Thanks,

 

- m

Outcomes