0 Replies Latest reply on Apr 19, 2016 1:17 PM by maddie

    Sending a Text Message with the Send Email command

    maddie

      I have been assigned the task to send a text message to a person through FileMaker with the Send Email command. Here is how it works:

       

      I have a user with their name and they supply their phone number and carrier. The carrier defines which SMS code to use to turn their number into a "email". For example, John Doe's phone number is 338 502 9700, and his carrier is Verizon, meaning his extension is @vtext.com. When the script is running (to send the text), the database simply merges the number and the carrier extension, and the "email address" is 3385029700@vtext.com.

       

      The message itself is predetermined by two dropdowns for the subject line (which appears bold in the text message) and the message itself.

       

      The Send Email command is set to "Send via SMTP Server". The SMTP options window displays as the following:

       

      Screen Shot 2016-04-19 at 1.45.14 PM.jpg

       

      Don't worry, I assure that the blurred fields have been filled properly with an email address, email server, server port, and the email for the authentication username.

       

      This is the only script step in the script.

       

      On my phone, I have the same email address in my Mail app so then it will work accordingly with FileMaker. When I go into Settings on my phone and to the mail tab, whenever I try to change the port number under advanced, the header displays "Verifying" and spins for a while before displaying the following error:

       

      "The IMAP server 'server name here' is not responding. Check your network connection and that you entered the correct information in the 'Incoming Mail Server' field."

       

      I have re-typed the server, username and password for said "Incoming Mail Server" block with similar results. When I tap on the "Outgoing Mail Server" block the server that I am trying to use is presented as the Primary Server. I tap on that and it is here that I can change the server port and tap done with no errors what so ever. I move back to the Account Detail, re-type in the server, username and password and that commits the mail account and takes me back to the main menu for the email (where it displays if I want to see emails and notes sent to the account). To make sure that the email works, I sent a email back and forth between two emails of mine (one a @mac and the other a @gmail account) before confirming that I could send emails and proceeding.

       

      When I push the button on my iPhone, I receive the error code 1503: "There was an error with SSL.". It does not deliver a detailed error report either so I do not know what causes this.

       

      I have a similarly coded script for the Desktop and WebDirect, minus the fact the port is one digit less:

       

      Screen Shot 2016-04-19 at 2.05.58 PM.jpg

       

      This, for some unexplained reason, works for the Desktop and WebDirect, but when I try this button on the iPhone, I get the error 1506: "Email(s) could not be sent successfully.". Even after updating the Outgoing Mail server to match the information here I continue to get the same error.

       

      I am convinced that it is some setting on my phone, which is a iPhone 6 version 9.3.1, that is causing the 1503 error.

       

      I am trying to do this without the use of a plug-in or a third party solution (such as Twilio) as it was requested to be completed without a plug-in or a third party solution.

       

      Does anyone have any ideas or suggestions that may help solve this issue?