3 Replies Latest reply on May 20, 2016 10:20 AM by TSGal

    ESS login window blank

    studietz

      Product and version: FileMaker Pro Advanced 14.0.5

      OS and version: Mac OS X El Capitan 10.11.4

      Hardware: MacBook Pro Retina 15" late 2013, 2.6 GHz i7, 16 GB RAM

      Other technologies: ESS data source is an Oracle 11gR2 database

       

      Description:

      When navigating to a layout or panel displaying fields from related records in multiple ESS tables, without first having authenticated to the ESS data source, the ESS login window that appears is completely white/blank. Interestingly, it's still functional, as I can type my credentials, tab between the username/password fields, and press enter to successfully authenticate. However, it took me a long time to realize this; at first I had assumed FMPA had frozen and that I needed to force quit, and I imagine most users would do the same.

       

      See attached screenshot of the blank ESS login window. Note that in the screenshot, I've clicked on the "Warehouse Lookup" tab; that's where the ESS fields are and what prompted the ESS login window to appear.

       

      How to replicate:

      - This appears to only be an issue when the destination layout/panel displays fields from multiple ESS tables. The ESS login window appears correctly when the destination layout/panel displays fields from only 1 ESS table.

      - This appears to only be an issue for FileMaker Pro Advanced 14.x on the Mac. The ESS login windows appears correctly for regular FileMaker Pro on the Mac, and for FileMaker Pro/Advanced on Windows.

      - I am able to replicate this behavior, with the particular setup described, every time on multiple databases.

       

      Workaround (if any):

      Authenticate to the ESS data source before navigating to a layout/panel displaying fields from multiple ESS tables; either by doing a scripted Open File on the external data source, or by navigating to a layout/panel displaying fields from only one ESS table.