12 Replies Latest reply on Apr 23, 2016 10:55 AM by yomango

    Hidden fields

    yomango

      Hello. I came across a file in which one of the layouts shows the fields on table view ONLY , but not on Form, List views NOR  Layout Mode. I thought the fields were hidden, so I called the "Select All" command  in Layout Mode to get the outline of all selected fields, but nothing happened. I like this way of hiding fields but I can't figure out how is it done. Thank you in advance for an insight.

        • 1. Re: Hidden fields
          erolst

          These fields are not really hidden; they were added using the Modify Table View dialog.

          • 2. Re: Hidden fields
            beverly

            in Table View, Browse mode, click the "Modify" button in the upper right.

            it is a feature of the Table View. you can adjust the fields shown here, even though switching to Form View can have completely different fields.

            I wrote an article on and interface trick for making the swap 'smooth' to the user:

            you don't necessarily need to make the header changes that I did, but it will show you the difference in the same layout between the two views.

            beverly

            • 3. Re: Hidden fields
              yomango

              Thank you, Erolst and Beverly for your prompt advise/answer but "no cigar", as I once learned to use this phrase. The Modify Table View does allow me to hide or show fields IN Table View, but that's not my confusion. It lays on the fact that if I go to Layout Mode, there aren't any fields I could click on to use the "Hide Object when" option, the layout shows no fields. How can fields  hide in layout mode; and if it is possible to hide them, how can I get them back so I could modify their hide options?, Any ideas?

              • 4. Re: Hidden fields
                beverly

                The Form view (or List view) fields and the Table view fields can be different.

                 

                Yes, if you are in Layout mode you view as if you would see records in List or Form views.

                You must add fields.

                 

                First Select all (Edit menu) to verify you don't have object hidden or colored the same as your background.

                If you see any "selection" squares, then you have objects on the layout.

                If you don't have any objects:

                To add fields, use the Field Picker (upper right, near where the "Modify" button was in Browse mode.

                This allows you to select and drag fields to the layout. Perhaps this help topic will get you started:

                https://www.filemaker.com/help/14/fmp/en/html/edit_layout.10.39.html

                 

                Also, if you have not done so, take a look at the tutorials and videos on this forum (Resources, footer menus)

                beverly

                • 5. Re: Hidden fields
                  yomango

                  Thank you for your patience. I think I am not making myself understood: how is it possible to see records on Table View only but no fields show on Layout Mode. One goes from Browse Mode (Table View) to Layout Mode and the layout is blank. As I said before, I choose Select All and not selection squares show.

                  • 6. Re: Hidden fields
                    beverly

                    I don't think you understand my first sentence in the last post from me.

                     

                    Layout mode can have fields or NOT have fields.

                    Go to Browse mode and select Table View, you can use Modify to place or remove fields for TABLE VIEW ONLY.

                    Table view is a special type of layout that does not relate to the Form view or List view, unless you happen to have the same fields on the layout (placed while in Layout mode). If you create the form or list (in layout mode) and then show the table view, those fields will automatically be placed there. UNTIL you manually remove or add fields (in browse mode).

                     

                    A single layout can be used twice:

                     

                    1. Layout mode for placing fields for Form or List view. Switch to Browse mode and select Form or List view.

                    OR

                    2. Browse mode for placing fields for Table view. No need to switch modes.

                     

                    If it's too confusing, you can limit what modes can be seen from any given layout.

                    • Edit the layout. (button in Browse mode)

                    • Click the pencil next to the layout name (now in Layout mode)

                    • In Layout Setup dialog, click on the Views tab

                    • UNCHECK any view you do not want to be associated with a layout. The user will not be able to switch to the those unchecked.

                     

                    beverly

                    • 7. Re: Hidden fields
                      yomango

                      LOL. I do understand what you are saying. I have designed many FM solutions. i know what is a Form, List and table Views.

                       

                      I came across this file that is baffling me because;

                      1.Form and Table Views are chosen.

                      2. Form View does not show any records.

                      3. Switching to Table view, all record fields are shown (I can also choose what fields I want to hide by using the Modify button)

                      4 From Table View I go to Layout Mode and there are no fields. How is that possible? where did the fields go, how can I format a field if  no field shows on layout. I can drag any field into the blank layout, yes. But where was that field to begin with that  shows on Table view but not on Layout. Do you follow me?

                      • 8. Re: Hidden fields
                        yomango

                        Hi, Beverly. I just figured out; perhaps I wasn't looking at your instructions as I should. I can create a blank layout,choose Table View only and on Browse Mode pick the fields I want to see with the Modify button. If I go to layout, no fields will show. Nice , I did not know that could be done, I had never used the Modify Table view button. Thank you for you patience and interest. God bless

                        • 9. Re: Hidden fields
                          beverly

                          Excellent! Yes Table view has it's special features.

                          beverly

                          • 10. Re: Hidden fields
                            rgordon

                            Because of  those "special" features, table view can give your users access to things that you might not want them to have access.

                            • 11. Re: Hidden fields
                              beverly

                              Exactly! with permission, of course, one can Modify a Table view.

                               

                              Working with data in Table View

                              right at the top it says:

                              Note  You must log in using the Full Access privilege set to modify fields in Table View.

                              beverly

                              • 12. Re: Hidden fields
                                yomango

                                Thank you again beverly, erolst and rgordonfor your interest, time and patience. That Modify Table View buttons is an option that I am just discovering. Very nice.