3 Replies Latest reply on May 6, 2016 11:18 AM by TSGal

    Field Picker Issues

    Dddavid

      OS X El Capitan 10.11.4   -   Filemaker Pro 13.0v5    &     Filemaker Pro Advanced 13.0v9

       

      I have a draft solution, that I began building on Pro 13, and I have no Field Picker issues with those drafts.

       

      I purchased a copy of Pro Advanced 13, and continued my building on clones of the original drafts.

      All those copies have the following field picker issues:

                -     cannot search in the FIELD PICKER

                -     fields disappear if I use/change the "Table Selector" in the FIELD PICKER

                -     The NEW FIELD button in the FIELD PICKER does nothing

                -     Clicking the DRAG OPTIONS does not alter the Picker window         

       

      I then created, with Advanced, an empty database, and I copied and pasted individual fields from my PRO (no issues) drafts, AND my ADVANCED (buggie) drafts, and there are still NO Field Picker issues

       

      I then attempted to Import, into the latter new database, a complete Table, from my Advanced (buggie) drafts, and there are no Field Picker issues UNTIL., I choose the newly Imported Table, from the Field Picker, and from then on, I have all of the same Field Picker issues, throughout the whole file.

       

      I am fairly new at, properly, building solutions, although, I have been studying on and off for several years.

      This is my first serious attempt at making something of worth, in hopes that I can introduce it at the office.

       

      I am VERY concerned that I have stability issues, due to this situation, and that, in turn, leaves me with a sense that all of my work and effort will be unreliable, and useless.

       

      I did not see a resolution, yet, to this situation, although, I will continue searching.

       

      I am taking a chance that someone might have the EUREKA response to my situation.

       

       

      Many Thanks!

        • 1. Re: Field Picker Issues
          TSGal

          davidlaramy:

           

          Thank you for your post.

           

          From your description, it appears your original table may be damaged.  Creating a new table and copying and pasting the fields appears to work.

           

          Try running Recover (from the File menu) on the original file, open the Recovered file and see if the problem persists.

           

          Also keep in mind that FileMaker Pro 13 was not tested under Mac OS X 10.11.x.  However, it appears most actions appear to work under Mac OS X 10.11.x.

           

          TSGal

          FileMaker, Inc.

          1 of 1 people found this helpful
          • 2. Re: Field Picker Issues
            Dddavid

            Thanks for the response TSGal

            I actually have 69 tables, some of them containing over 100 fields. 

            Some of the tables may need to be weeded out, but that is a different discussion.

             

            I have tried using some tables, that were created with Pro 13, as well as the tables created with Advanced 13.
            Those copies had the same Field Picker effect.


            I have not created any relationships yet, as I was just starting to build the layouts.

             

             

            I will perform a Recovery, a see what the outcome is.

             

            -----

            When you mention that "most actions appear to work under Mac OS X 10.11.x", are you referring to my experience, or the overall feedback in the Filemaker Community?
            In the case of the latter, I would consider that a good indication of my chances at succeeding what I am attempting to accomplish.

             

            -----

            For me to introduce a Filemaker Solution, to my work environment: I have an uphill battle trying to encourage individuals of the gains to be made, as they would probably all have to make the investment of time and money.

            We all, through our union, have full access to Lynda.com, although, most of my co-workers do not speak English as their first language, and that has a large impact on their willingness.

             

            We are all contractual ( <6 months ) employees, so long-term commitments and/or trying to enforce the Filemaker use, with a hiring pre-requisite, is not an option, particularly given the fact that I am trying to sway superiors, who have their own successful procedures.

             

            I have been trying the "more carrot" and "less stick" approach, with mixed results, although, I am optimistic.

             

            I do, however, feel more confident, with your input.

             

            Regards,

            DAvid


                

            • 3. Re: Field Picker Issues
              TSGal

              davidlaramy:

               

              If the Recovered file still has the same issue, then create a new table in the same file, create the same field names and field types as the original table, and in the new table, import the records from the original table.

               

              The "most actions appear to work under Mac OS X 10.11.x" is mostly from experience and from feedback from other users.

               

              Let me know if you have any other questions/concerns.

               

              TSGal

              FileMaker, Inc.

              1 of 1 people found this helpful