9 Replies Latest reply on Aug 11, 2017 3:45 PM by jbardwell

    Help a Dummy

    jhendrixenterprises@aol.com

      I use Filemaker Pro to keep up with classified documents that are pdf. I am far from a pro user. In Pro 13 ( Individual License) I had all my documents in container fields. When I clicked on the container field, I could read the documents. Now that I have upgraded to 15 Pro ( Individual License), I can no longer see the documents. All I see is a pdf icon. I have hundreds and hundreds of documents. Please help. I could never replace all the documents over the last few years. When I go to inspector, pdf files are checked in data, but when I click on a empty container to add a pdf, it has pdf shaded out. I have Adobe extensions on all my web browsers. I am sure it is a plugin problem but I have no clue how to fix it. Can someone please help me?

        • 1. Re: Help a Dummy
          JEDtech

          FileMaker uses the same tool as the web browser on the platform you are on to display PDF content.  You didn't mention anything about your environment:

           

          Mac or Win -- if Win 32-bit or 64-bit

          If Mac try removing the Adobe web browser extension

          • 2. Re: Help a Dummy
            jhendrixenterprises@aol.com

            Win- 64, WIndows 10. It is not working  then. I have Adobe extensions on both Firefox and Chrome, but Edge uses their own. Could that be the problem?

            • 3. Re: Help a Dummy
              hschlossberg

              It sounds like you're on Windows.  Since FileMaker is a 64-bit application, it uses the 64-bit version of Internet Explorer to render.  That's not a problem because if you have a modern system, then IE is already installed as both 32-bit and 64-bit and it automatically renders using the correct engine. 

               

              The problem is that IE can't do PDFs by itself.  It relies on a PDF extension.  When you install Acrobat Reader, for example, it will automatically add the extension to IE.  And if you have a somewhat older version of Acrobat, then it was only installed as a 32-bit extension.  You need to upgrade to a newer version of Acrobat and it will install the 64-bit extension and should make everything right with your world.

               

              (Or it might just add to your troubles and ask you every time you switch records whether you want to view or save the PDF from the container.  That's what I'm currently dealing with, and I know I once had a solution for that.  But that's a different topic from what you've asked.)

               

              Hope that helps...

              Howard

              • 4. Re: Help a Dummy
                jhendrixenterprises@aol.com

                Thank you for your reply. I have Adobe DC Pro subscription. It is up to date. I also have FM 13 on same computer and pdf work fine in containers. It has to be something in FM 15 that I am missing. I will just use 13 I guess till I can figure out the problem or....not . Thanks again

                • 5. Re: Help a Dummy
                  jhendrixenterprises@aol.com

                  Problem solved. I installed 64 bit and Adobe Acrobat DC Pro will only work on 32 bit. Pdfs are opening in all container fields now since I downloaded 32 bit and uninstalled 64 bit.

                  • 6. Re: Help a Dummy
                    hschlossberg

                    You should be able to use 64-bit of FM if you install the regular version of Reader (not the DC version, or in addition to DC). 

                     

                    Neither FIleMaker nor Microsoft nor Adobe make this very simple.  I had this working with FM14 and 15 a few weeks ago, after wrestling with it for an hour back then.  Now you have me checking again and it was again not working. (I'm on Windows 7, 64 bit).  When I opened IE, went to the gear icon, selected and "Manage Add-Ons", I got the image below.  Select "All add-ons" in the lower left and then you should see Adobe PDF Reader and it should show 64-bit for it (or 32-bit if you are using the 32-bit version of FileMaker).  It was no longer there on mine, so I downloaded and installed a new copy of Adobe Reader (NOT the "DC Digital Cloud" version) and it properly installed the add-on as shown below.  Since I never use IE, the only thing I can imagine would have removed the 64-bit version of Acrobat from IE might be a Windows update. 

                    adobe_ie.JPG

                    Hope that helps...

                    1 of 1 people found this helpful
                    • 7. Re: Help a Dummy
                      jhendrixenterprises@aol.com

                      Thank you for your reply. I uninstalled the FM 15 64 bit version on my 64 bit computer and downloaded the 32 bit version of FM 15.  Now all container fields are opening correctly. You might try this so you can use DC version of Acrobat, if you need it.

                       

                       

                       

                       

                      Joyce Hendrix

                      jhendrixenterprises@aol.com

                      • 8. Re: Help a Dummy
                        nerosunero

                        I had same problems last night

                        I followed your advice I uninstalled the FM 15 64 bit version on my 64 bit computer and downloaded the 32 bit version of FM 15, but this didn't solve the problem with me.

                         

                        Today I read on the Official Filemaker Documentation that for Filemaker 15 on Windows you must sure that a web browser plug-in (such as Adobe Reader) is installed on your local computer. If it is not installed, Insert menu > PDF will be unavailable.

                        I had Adobe Acrobat DC installed on my local machine and this worked perfectly for previous versions but I needed to install Acrobat Reader DC for solving my issue!!!I

                        I did and now all the PDFs show finely on Field Containers in File Maker Pro Advanced 15 either 32 or 64 bit!!!!

                        1 of 1 people found this helpful
                        • 9. Re: Help a Dummy
                          jbardwell

                          Installing Adobe Acrobat Reader DC did the trick for me on Windows 8.1 64 bit computer. Already had Acrobat X Pro installed, but that appears to be only 32 bit. Acrobat Reader DC is 32 bit & 64 bit.