Fred(CH)

Display new script on Scripts menu preference ignored

Discussion created by Fred(CH) on May 17, 2016
Latest reply on May 9, 2017 by TSGal

Product and version

FileMaker Pro 15.0.1

OS and version

OS X 10.10.5

Hardware

iMac Retina 5K 27'' Late 2014

Description

The Script workspace preference pane of FileMaker 15 allows us to not include new scripts on Scripts menu by default. However, if the script is created directly from a button in layout Mode, this preference does not apply.

How to replicate

Make sure you have unchecked the preference that include new scripts in scripts menu : using the Script Workspace, menu command DISPLAY > SCRIPT WORKSPACE PREFERENCES…

Back in layout Mode, create a button and a new script using the button's configuration panel.

Workaround (long version) : close all the dialogs, go to the script workspace and using the appropriate menu, exclude the new script of scripts menu.

Outcomes