7 Replies Latest reply on May 19, 2016 6:37 PM by Lasersol

    WebViewer Quits Working

    Lasersol

      My Webviewer was working fine with FMA 14 but has suddenly quit working. I can copy my solution to another laptop, and to iOS and things work fine. I have replaced the viewer on my layout, saved a copy of my solution, tried another solution that used to work but it no longer works either. Anyone ever have Webviewer quit working?

       

      Suggestions please!

        • 1. Re: WebViewer Quits Working
          beverly

          Do you have any plug-in installed or external apps that might interfere with the default browser. What OS? What version of FMA 14 (exactly)?

          beverly

          • 2. Re: WebViewer Quits Working
            Lasersol

            Hi Beverly. I should know better...


            Mac OS 10.10.5


            FMA 14 (I just downloaded an update and now at 14.0.5)


            No plug-ins installed


            Webviewer connected to Amazon S3 and working as it has been for six years.


             

            Here's what led up to this...

             

            We have a lot of cross-platform video that has worked perfectly for a decade with FM and QuickTime. Now with Apple’s 'abrupt' decision to discontinue support for QuickTime on Windows, we found the Open-Source VLC replacement for QuickTime as a bandaid (or longterm solution) as a QT player replacement. 


             

            We have new cross-platform video-based solutions that we are near launching and Apple's departure from support for the standard that it created is more than a bit disheartening. It's causing us much frustration and uncertainty into strategic decisions at a time in projects in which distractions like this are not needed. I view Apple's actions as disheartening.

             

            There have been no suggested paths for workarounds from either Apple or FileMaker. If Apple doesn’t want to support QT for Windows, what are the options and alternatives and how do they directly affect FileMaker Developers and Users?


             

            To help establish the future, I have jumped back into research and experimentation to find out what is going to work for the future. Oh, things worked so well before…


             

            MPEG-4 is the basic standard of the world and it was built upon QuickTime. '.MOV' was QuickTime, '.MP4' became the standard and then Apple revised the standard optimizing for Apple products and it became '.MV4'. 


             

            I read that you could change the extension from .MV4 to .MP4 and you would disable some of the Apple-specific features but readers would interpret the Apple MPEG-4 video as MPEG-4 and still play it. I tried it and when I played it through the FileMaker Container, it seemed to work!

             

            Then, I got brave (or stupid) and changed my .MOV to .MP4 and attempted to run them through the Webviewer.

             

            In the process, I think I corrupted my install of FM 14 in the process. I then downloaded 14.0.5 and updated and the problem still exists.

             

            When FileMaker is releasing a new version, I respect that they want everyone to go that route. I’ve been on the leading edge for 35 years and have also been on the bleeding edge in many of those years and understand the difference.

             

            I want to continue our products with FM 14 and release them in several weeks and then after that, we’ll begin our implementation of FM 15.

             

            I think I need a fresh install of FM 14 to overwrite my corruption of the Webviewer my experimentation and I think Apple and FileMaker need to provide guidelines and suggestions for workarounds.

             

            What do you think?

            • 3. Re: WebViewer Quits Working
              Lasersol

              Continuing troubleshooting...

               

              1. Got the latest 14.0.5 update installed - no effect

              2. Installed FM 15 - no effect

              3. Created a new file - no effect

              4. Created new layouts - no effect

              5. Tried running apps that used to work - web viewer no longer works with them

              6. Put the URL into a browser - it works

              7. Turned the Apple Firewall off - no effect

              8. Examined Norton Security - I had blocked a request for port 52150 about the time the problem occurred

               

              Web Viewer will not work with FMA 14 nor FM 15.

               

              Any ideas?

              • 4. Re: WebViewer Quits Working
                beverly

                post a link to this thread in Product Issues:

                Report a Product Issue

                 

                TSGal & TSPigeon

                will see the post and may have other ideas.

                beverly

                • 5. Re: WebViewer Quits Working
                  TSPigeon

                  Lasersol:

                   

                  Thank you for your post and your information.

                   

                  To confirm, at this point the issue is that a WebViewer will not display anything in FileMaker Pro 14 (Advanced) or FileMaker Pro 15 on OS X 10.10.5, but you are able to use your solutions and WebViewers on other computers?

                   

                  It seems you have tried running Video Files through the WebViewer. Will the WebViewer display something simple like: https://www.google.com/ ?

                   

                  I look forward to your response!

                   

                  TSPigeon

                  FileMaker, Inc.

                  • 6. Re: WebViewer Quits Working
                    Heidelberg

                    I just responded to a question where the WebViewer did fail to play .m4a file. The fix: add to the local path field used as reference for the web viewer the extension ".mp4". It appears that FMP is happy getting a reference with a suitable ending regardless of how the real file ends.

                    • 7. Re: WebViewer Quits Working
                      Lasersol

                      I had almost excellent troubleshooting experience at the NorthPoint Apple Store at the Genius Bar. We spent over an hour trying different things and it was rewarding to work with an experienced engineer who understood the problem.

                       

                      I was running Yosemite and upgraded to El Capitan and the problem was resolved during the upgrade process.

                       

                      I also attended an excellent iMovie workshop at the store and got more answers about converting from .mov to .mp4.

                       

                      Just wanted to say that the problem appears to be resolved. Me thinks it was deep within the OS.