JeffHenry

FMS 14.0.4b - Databases stuck in Closing state

Discussion created by JeffHenry on May 20, 2016
Latest reply on Feb 16, 2017 by TSGal

Hi FM Community,

 

I have a client running OS X 10.11.5 with FileMaker Server 14.0.4.414 and we run into an issue when closing files. Upon closing a file, the connections get disconnected but the file state gets stuck in "Closing". However, if I check the Log Viewer, a log is generated saying the database was closed. I've waited a reasonable amount of time for the Admin Console to update, even tried relaunching it, but it never leaves the "Closing" state. Therefore, i never get the option to re-open the file or download the file.

 

I've attempted to restart the admin console via terminal. This is where it gets bad. Once logged into the admin servers, the databases never load into the admin console. The Activity Log goes empty and the main Status screen will report "0 Databases hosted out of total 0". After this, the client reports that they cannot access their files. I believe this issue is probably because i'm restarting the admin server while it is stuck closing a file.

 

At this point I have to do a full reboot of the machine to get it back into a functional state.

 

I've tried toggling off the database server and toggling it back on to reset the server and that hasn't resolved the issue.

 

When I try to re-deploy the server, it ends up freezing and never completing its re-deployment.

 

I have a feeling i'm just going to re-install FMS on the machine over the weekend, but I would like to hear if anyone has experienced this issue. Unfortunately, no crash logs get thrown by this issue so I can't attach any hard data.

 

Edit: Forgot to mention: We were experiencing an issue with a particular file that may have been corrupt so I will provide updates if that ended up being the fix.

 

Thanks!

- Jeff Henry

Outcomes