4 Replies Latest reply on May 25, 2016 4:11 AM by Mike_Mitchell

    Open remote and FQDN

    KennethGravdal

      Just installed my first FMS15 and added a SLL-cert to it.

       

      Now I have a question that I hope someone is able to help me to solve: When this server is displayed in "Open Remote"-dialog/Launch Center it does not present it self using the FQDN (essential for making SSL to work properly).

       

      Using FMPA15 on a mac or a PC, it shows up in the server-list by itself, and what I see is the FQDN ("fmserver.mydomain.no")

       

      BUT: when open the Network File Path-dialog on the server, this is what I see (and what is used to connect to the published databases):

      On Mac it presents itself as fmnet:/fmserver.local/

      On PC, it presents islet as foment:/192.168.xxx.xxx/ (its IP address)

       

      The work around is to add the server as a favorite host using its FQDN. Then the padlock is green and everything is fine...

       

      Is there a way to make FMS show up in Launch Center using its FQDN also for network path?

       

      Anyone else experiencing this?

        • 1. Re: Open remote and FQDN
          bigtom

          No way around this that i have found. If you have the proper DNS settings that allow the FQDN on the local network that  is about the best you can do.

           

          I suppose you might modify the host files on all the local clients to direct to the local IP when the FQDN is used. not sure how this would interact with the launch center. Never tried it.

          • 2. Re: Open remote and FQDN
            KennethGravdal

            DNS is not the issue. I have updated DNS on our domain so connecting to the server using its DNS-name (=FQDN) is OK.

             

            The problem is that the server does not use this name when it presents itself to the clients.

            • 3. Re: Open remote and FQDN
              bigtom

              Like I said. Host file changes might work.

               

              Launch center will only auto look for local hosts using IPv4 or IPv6 so far as I know.

               

              I put in a feature request for adding a favorite host via assisted install but not the best answer.

               

              Maybe if your DNS server is assigning unique Names on the same FQDN (machine1.domain.com) to all the clients it might work. Never tried. Just throwing out some ideas.

              • 4. Re: Open remote and FQDN
                Mike_Mitchell

                Can you add the host DNS name as a Favorite?

                 

                Edit: Never mind. I see you already tried that.