2 Replies Latest reply on Jun 21, 2016 2:01 PM by TSGal

    FileMaker 15 Import Tab-Delimited Not All Fields Can be Imported

    JEDtech

      Product and version: FileMaker Pro Advanced 15.0.1

      OS and version: Mac OS X 10.11.5

      Browser and version (N/A)

      Hardware: MacBook Pro 2013 with 16 GB RAM

      Description

       

      I'm importing a tab-delimited file which is a tabbed XML file but I am importing it as a .txt file.  The import dialog present f1-f7 for import but at record 804 and beyond there are fields with more tabs than that.  It appears that FileMaker is only scanning a limited number of records to determine how many fields there are to import.  Even if I arrow through to 804 and it displays the data in the 8th field that appears there I still can not click on the icon to enable importing it to f8

       

      How to replicate

       

      Easiest way is to generate an XML DDR of a complex FileMaker database, change the suffix from .xml to .txt and create a new database from it.

       

      Workaround (if any)

       

      Using a text editor create a first line that has:

       

      f1<tab>f2<tab>f3<tab>f4<tab>f5<tab>f6<tab>f7<tab>f8

       

      and then treat the first line as field names.

       

      It would be nice if there was a checkbox on the Import dialog that would force FileMaker to scan the entire file instead of however many lines are being scanned now.

       

      The documentation should also mention how much of an input file is being scanned to determine the number of fields being imported.