4 Replies Latest reply on Oct 25, 2016 12:12 AM by Jacobi

    Upload to Filemaker Server - Connection Failed

    Jacobi

      The server where I want to upload is on the same LAN.

      In FM15 I choose Upload to Filemaker Server and when I choose the local server. Fill in credentials (what sometimes isn't possible) and click on next. Immediately I get the message Unable to Connect.

      I also tried with the FM14 installation I still have but the same problem occurs and get the message Unable to Connect.

      I've found  more messages of people with this problem and tried possible solutions (ssl on, check ports etc) but with no positive effect.

        • 1. Re: Upload to Filemaker Server - Connection Failed
          TSGal

          Jacobi:

           

          Thank you for your post.

           

          Do you have a firewall enabled?  If so, temporarily disable it.  Does this work?

           

          Are you able to connect to any hosted file using FileMaker Pro 15?

           

          If you install FileMaker Pro on the server machine, and try to upload a file to the local IP address, does it work?

           

          What can you tell me about your server?  Operating system and version?  RAM?  etc.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Upload to Filemaker Server - Connection Failed
            Jacobi

            TSGal Thanks for your answer.

            No internally I don't have a firewall.

            Connecting and opening databases is no problem.

            The Filemaker Server is running on Mac Os X El Capitan 10.11.5 8GB memory

             

            I've installed FM Pro on the server itself and tried to perform the Upload to Server command.

            The next steps I tried:

            1st

            In Upload to Server I choose Local Hosts and selected the local server.
            The strange thing is I can't fill in my credentials. I can't go 'in' the Name or Password Field.

            2nd

            Now I go back to launchcenter and add a new favorite server: localhost. The databases show up and I go back to the Upload to Server. Now I select the server from the favorites but still I can't 'go in" the field to fill in the credential.

            3th

            In launchcenter I add a server of a client of my (also FM15 server). Back in Upload to Server I select this server and I can fill in the credentials press connect but get the Connection Failed message. Still in Upload to Server I select the localhost again. Strange thing is that the credentials of my clients server still is in the fields but now they are grayed out and again I can't go in the field again.

             

            Thanks for the effort!

            • 3. Re: Upload to Filemaker Server - Connection Failed
              tweller860

              Jacobi,

               

              Has there been any resolution to your problem? If not answered here, is there a knowledge base article or similar resource where you found your answer?

               

              I am currently dealing with an identical issue. I am working with a new install of FMS 15.0.2 (from the installer, not an update of 15.0.1), and am seeing the same response in the "Upload to Server" dialog. When attempting to enter the Admin Console credentials, I receive the "Connection Failed" error message if I'm lucky enough for the system to accept the credentials.

               

              I have done an internal port scan using Network Utilities and an external port scan using a web resource. In both cases, the expected ports (particularly 443) are reported as being open. I receive the same error when attempt to upload files from my laptop or from an instance of FileMaker Pro running on the server.

               

              Any insight or advice you can provide would be greatly appreciated. Thank you.

               

              Best regards,

               

              TW

              • 4. Re: Upload to Filemaker Server - Connection Failed
                Jacobi

                Hello,

                 

                No it's still a mystery for me why it doesn't work with some servers.

                Finally the only solution for me was to manually add the files in the databases folder on the server..

                The only thing you have to make sure is that the read/write settings of the manual added files are correct.

                Otherwise you'll get a message when you create or change a record.

                 

                Hope this will help you for now.

                 

                Best regards,

                 

                Hans Rein