3 Replies Latest reply on Jul 14, 2016 1:52 PM by planteg

    Ingres ODBC import error

    user27087

      Hello all. Hoping someone has tried working with FMP imports from Ingres tables in the past. We've worked with many SQL sources (both ESS and other) and have never encountered the problem we are having with Ingres.

       

      We are attempting to import data from Ingres tables using the simple Import Records, DSN, etc. Even if we create the simplest possible SQL (select one column name with no other commands) we are receiving a warning:

       

      SELECT on table Chemistry: No GRANT or GRANT compatible permit exists (#3502)

       

      The credentialed user has fairly high-level access to the tables, so they most definitely have the ability to read the tables. One thing that may be causing the problem is that the Ingres ODBC Administrator includes a checkbox option of Read Only. We are using this because we must be very careful with the data, and it is convenient that the driver included this as an option which is a great idea. I did not try with the checkbox unchecked just yet because we are waiting for user credentials that are read only for all tables, and I am not permitted to change anything on the driver.

       

      I am writing this before we hear back from IT because they tend to take weeks to reply to email, if they bother to reply at all. (I am definitely stepping on toes by running rings around their SQL programmers, so there's little hope they can help me.)

       

      Thanks.

       

      Scott