10 Replies Latest reply on Jul 24, 2016 1:23 PM by CICT

    Filemaker Go 15 and Windows PC

    gawendt

      I am working on a solution for a customer that runs Windows.  I would like to use an iPad with this solution so I turned on Network file sharing but the iPad does not see the file.  It does see the Host but when I tap on the Host, the app says that no files are found.  I am running Filemaker Pro 15 and Filemaker Go 15.  What am I doing wrong?

        • 1. Re: Filemaker Go 15 and Windows PC
          wimdecorte

          Do you have at least one account with the "fmapp" extended privilege assigned to it?

          In the sharing settings, on the right there is also a choice to show it to what users.  Make sure it is set to "all users"

          • 2. Re: Filemaker Go 15 and Windows PC
            schamblee

            The file has to be open with file sharing on turn on.  Verify your security setting. 

             

            About accounts, privilege sets, and extended privileges

             

            Opening files as the host

            • 3. Re: Filemaker Go 15 and Windows PC
              gawendt

              I verified I am using the Admin account which has “fmapp” extended privilege assigned to it.  I had already chosen ‘All User’ in the Sharing dialogue.  I still get the no files response.  I tried setting up the Host in Filemaker Go by using the IP address displayed in the Sharing dialogue but this too failed to show the app.

               

              Thanks!

              • 4. Re: Filemaker Go 15 and Windows PC
                rgordon

                Do you by any chance have another version of FileMaker Pro opened? If yes this will cause problems when trying to connect. 

                • 5. Re: Filemaker Go 15 and Windows PC
                  ron.harris

                  I had the same problem.  As for my situation, there is an external IP specifically for FM GO and it was reporting the same as you have stated.  It was either a firewall issue or a port issue, I don't quite recall.  Ports 80, 443, 5003 need to be open and if they are, check your firewall.  FMGO works very well.

                   

                  I hope this helps.

                  Ron

                  • 6. Re: Filemaker Go 15 and Windows PC
                    gawendt

                    Ron,

                     

                    I am running Avast’s Firewall and I checked and it has rules for Filemaker which open the ports you suggested.  I still don’t see the file in FM GO.  Any additional thoughts?

                     

                    Thanks

                     

                        Greg Wendt

                    • 7. Re: Filemaker Go 15 and Windows PC
                      CICT

                      Hi Greg

                       

                      Suggest you temporarily switch off the Avast firewall and check the built in Windows one isn't enabled as well to totally eliminate the firewall issue.

                       

                      If that doesn't work, did you install Bonjour with FileMaker in the PC? If not, create a favourites host in FikeMaker Go pointed to the IP address of the PC (as you already have but with the firewall off and FileMaker running). If you have another copy of FileMaker on another computer on the network, see whether this can access the shared file.

                       

                      Check the wifi is on the same network range as the PC.

                       

                      If it works, look for specific 5003 port being open in both inbound and outbound rules within the Avast firewall, rather than just the app.

                       

                      If all that fails, revert back to the advice Wim has given you and check sharing is enabled for FileMaker Go.

                       

                      Andy

                      • 8. Re: Filemaker Go 15 and Windows PC
                        greatgrey

                        I have seen several times over the years with various programs including windows that an option is set to what should be the right setting but not working, and to fix it had change the setting to a different option and save it quit the program restart it then change it to what is suppose to be and restart(reboot) to get it to work.

                        • 9. Re: Filemaker Go 15 and Windows PC
                          gawendt

                          Hi Andy,

                           

                          All is well when I turn off Avast’s Firewall.  I tried altering the application Rules for the firewall without any success.  I set Filemaker’s rule to all ports in and out but it still didn’t work.  Looking at the Firewall Log it is Port 5003 inbound that is the problem.  Any thoughts???

                           

                          Thanks

                           

                              Greg

                          • 10. Re: Filemaker Go 15 and Windows PC
                            CICT

                            Hi Greg

                             

                            I don't know the Avast firewall software, but have had so many problems with all versions of 3rd party firewalls over the years.

                             

                            If you can find where to set the actual port inbound and outbound rules within Avast, rather than settings for the actual application, just ensure port 5003 is allowed in and out, then this should work.

                             

                            Good luck

                             

                            Andy