1 Reply Latest reply on Jul 20, 2016 12:58 PM by wkparkjoe

    SMTP with FMSA 10 Scheduled Scripts Fails

    wkparkjoe

      Hello:

      I'm having a major issue that only started recently. I still have some legacy databases running on my FMSA 10 machine. Recently as of last week my one database that I have a script that alerts staff with an e-mail when there are records to approve within the DB stopped working. According to the event viewer on the FM server I was getting a 1506.

       

      My e-mail environment is running on a MS Exchange 2007 server (which I manage). I've had FMSA and this database e-mailing to the Exchange 2007 server since 2009 at least with zero problems. After last weeks round of updates which could be confidential my database stopped e-mailing.

       

      I followed various links on the forum to possible solutions and I even implemented the following: Error 1506 - Sending via SMTP with FMS 12 by setting up hMailServer on the FMSA machine and have it relay into the exchange server. When I test using the Warning/Error notification function I have no issues. I can trace on the hMailServer logs the relaying and it goes right to my outlook.

       

      If I run the script on my FMA 11 locally on my PC and point to the FMSA as the SMTP server, it relays properly and the script works. However when I run it as a schedule, I no longer get the 1506 but I now get a 1502. I have anonymous SMTP relay setup internally only and the server is not accessible over the internet so this solution works.

       

      I know this is a legacy software and support for it is no more but I need to keep this going for a while longer until I can finish migration of the databases over to the latest FMS version.

       

      Within the script, the Name field in the SMTP settings is blank per recommendations from various forum posts.

       

      Any advise would be greatly appreciated.

        • 1. Re: SMTP with FMSA 10 Scheduled Scripts Fails
          wkparkjoe

          So I might have a solution. I'm still using the hMailServer application running on the FMSA machine as a SMTP relay agent but within my script instead of pointing to the internal URL I am pointing to the ip address of the FM server. So far it has tested successfully. I couldn't begin to guess why it suddenly started working again. Maybe my internal DNS has stale records or something isn't resolving properly. Maybe a windows update changed something who knows. I am sorry this is not a good solution to the problem but it seems to have worked for a legacy product. Hope this might help anyone else who is still running version 10 server.