6 Replies Latest reply on Aug 3, 2016 2:50 PM by TSGal

    Tooltips in webdirect 15

    oliver

      Hi,

       

      Tooltips is not working working with webDirect 15 but fine in webDirect 14.

       

      Does anyone noted this issue?

       

      Thanks.

       

      Oliver

        • 1. Re: Tooltips in webdirect 15
          TSPigeon

          oliver:

           

          Thank you for your post!

           

          Tooltips do seem to be working with WebDirect in IE11, Chrome, and Safari from a FileMaker Server 15. I used Tooltips on Buttons to verify this.

           

          Is this a solution specific issue or are you able to reproduce the lack of tooltips in a new file?

           

          TSPigeon

          FileMaker, Inc.

          • 2. Re: Tooltips in webdirect 15
            oliver

            Hi TS,

             

            Thanks for the follow up.

             

            After some further checking, it's a bit more mystery to me now.

             

            Technically speaking, I am unable to make tooltips worked on any new created objects on layout. Existing button object may work for some cases. I used simple text for the tooltips value, no calculation in the testing case. I have tried to use both FMA14 and FMA15 to config the tooltips setting.

             

            Similar case be tested on file hosted on FMS 14 and FMS 15. Same result, no tooltips showed.

             

            I can recall the tooltips feature is easy to setup and haven't encountered issue before. The tooltips are showed correctly when opening these files using FMPA.

             

            I have tested the cases on all supported browsers. Same results and I doubted it's not browser related issue.

             

            Strange, any clue and what I can help to confine the issue.

             

             

            Oliver

            • 3. Re: Tooltips in webdirect 15
              TSPigeon

              oliver:

               

              Were you able to test this out with a new sample file? I'm curious if it is specific to the file your are working in, since you were able to reproduce in both FileMaker Server 14 and 15. My tooltips are working in WebDirect for both Server 14 and 15.

               

              TSPigeon

              FileMaker, Inc.

              • 4. Re: Tooltips in webdirect 15
                beverly

                can you specify browser(s) and OS's that you tested?

                beverly

                • 5. Re: Tooltips in webdirect 15
                  oliver

                  Hi,

                   

                  I am testing all the above from OSX 10.10.5 using Safari 9.1.1 and Chrome 51.0.2704.103.

                   

                  After some further testing, I found that text box with tooltips is working fine. Button object and others seems not working well.

                   

                  I read the document on webDirect and found the following extract

                   

                  "Tooltips are not supported with the following layout objects: text, images, fields that do not allow

                  entry, merge fields, merge variables, portals, charts, and web viewers that do not allow

                  interaction."

                   

                  Not sure if button object falls into the group of "do not allow entry" item.

                   

                  If other cannot repeat my findings, I probably have some settings configured wrong or misread something. Al is working on FMP but not webDirect.

                   

                  Oliver

                  • 6. Re: Tooltips in webdirect 15
                    TSGal

                    oliver:

                     

                    Thank you for your post.

                     

                    I am unable to replicate the issue using Safari 9.1.2 and Chrome 51 to access the hosted file under Mac OS X 10.11.5.  The tooltip works fine for the buttons I created.  This is what I have done:

                     

                    1. In FileMaker Pro Advanced 15.0.1, I created a layout with three buttons with the options "Do Nothing", "Single Step" and "Perform Script", respectively.

                    2. I added a Tooltip to each button with the text values "Nothing", "Single" and "Script".

                    3. I verified in Browse Mode that the Tooltips worked.

                    4. I configured the file for Network Sharing and Webdirect.

                    5. I uploaded the file to FileMaker Server 15.

                    6. I accessed the file via FileMaker Pro to make sure the Tooltips still worked (they did).

                    7. I accessed the file via WebDirect, and the three buttons continued to show the Tooltips.

                     

                    Let me know what I am doing differently than you so I can reproduce the issue.

                     

                    TSGal

                    FileMaker, Inc.