0 Antworten Neueste Antwort am Jul 29, 2016 8:54 AM von anchhor

    Web viewer zeigt Bilddatei nicht an

    anchhor

      Hallo,
      ich habe ein Problem mit dem Webviewer. Ich lasse mir im Webviewer Bilddateien anzeigen, die auf dem eigenen internen Server liegen. Bei den meisten Dateien funktioniert dies ohne weiteres. Bei einigen Dateien bekomme ich jedoch nur das Kreuzsymbol für einen Fehler. Es liegt jedoch dieselbe Syntax hinter den Tasteneinstellungen für den Webviewer. So dass wenn ich den Webviewer anklicke das Bild wie geplant in einem externen Programm angezeigt wird.

       

      Dies ist der Code für den Webviewer:

      "data:text/html,

      <head>

          <style>body { border: 0; margin: 0; } img {display: block; margin: 0 auto;}</style>

          <script type='text/javascript'>

              function resize_image() {

                  var img = document.getElementsByTagName('img').item(0);

                  if (img.offsetHeight > img.offsetWidth) img.style.height = '100%';

                  else img.style.width = '100%';

              }

          </script>

      </head>

      <body onload='resize_image();'>

      <img src= '" &

        Wenn ( HoleNtenDatensatz (Bilder::basis_url; 1) = "*elephantine.smb.museum/bilder/fullsize/" ODER HoleNtenDatensatz (Bilder::basis_url; 1) = ""; 

          "//pk/smb/Mediadaten/Projekte/AEMP/Rubensohn-Bibliothek/ERC-Datenbank/bilder/thumbs/" & HoleNtenDatensatz ( Bilder::scan_dateiname; 1) & "-preview.jpg";

          HoleNtenDatensatz ( Bilder::basis_url; 1) & HoleNtenDatensatz ( Bilder::scan_dateiname; 1)) & Wenn ( HoleNtenDatensatz ( Bilder::scan_dateiname; 1) = "*.jpg"; ""; ".jpg") &

      "' >

      </body>"