AnsweredAssumed Answered

Uninstalling FMP 15 via Script in SCCM 2012

Question asked by aaron.s on Aug 5, 2016
Latest reply on Aug 18, 2016 by aaron.s

Hello all,

 

My company is in the process of upgrading our servers to FileMaker 15. My job is to automate the installation of the FMP 15 client to the individual user's computers. To do this we use SCCM 2012 as we have over 300 systems to install this to. I have the install working fine (deployed as an Application, not a Package), but I need to make an uninstall script for the client just in case. To do this I have written the following batch file:

 

REM ------Remove Extensions------

del "C:\Program Files (x86)\FileMaker\FileMaker Pro 15\Extensions\" /Q

rd "%userprofile%\AppData\Local\FileMaker\FileMaker Pro\15.0\" /Q /S

rd "c:\ProgramData\FileMaker\FileMaker Pro\15.0\ /Q /S

 

REM ------Uninstall FMP 15------

REM FMP Version 15.0.1.119

MsiExec /x {D5F969A0-E004-4A61-9CD6-F99CC9D32325} /qn

 

We have some plugins that we use, so the first section removes those. The second section uninstalls the program itself. When this is deployed via SCCM the script executes the first section fine, but when it gets to the uninstall part it just skips it, leaving the program on the computer. When i run this batch file locally it works perfectly. I have even tried ignoring the script and putting the uninstall part directly into SCCM and it skips it that way too. The logs say that the identifier key is wrong, but when I check the registry, which is where I got it from, they are exactly the same.

 

Any assistance would be greatly appreciated.

Thanks,

Aaron

Outcomes