mramaley

Internal Field ID Problem?

Discussion created by mramaley on Aug 8, 2016
Latest reply on Aug 8, 2016 by gdurniak

Hope some one can give me some help with this one, because I'm a little confused, and never ran into this problem before.

 

We run 2 FileMaker Servers with the same files (with the same tables and same data sets) on our network.  They are at our 2 corporate offices, and run on different subnets and are connected via a VPN.

 

Server A is running at 192.168.10.61

Server B is running at 192.168.15.30

 

We have internal DNS zones set up, so that when you are at one of the 2 locations, you connect the server that is at your location.

 

In my Manage External Data Sources, I have the reference pointed to the DNS name, so it looks like: fmnet:/local.filemaker/database_name

I can see the other server by manually changing the reference to: fmnet:/remote.filemaker/database_name

 

Every thing has worked perfectly.

 

Today, I tried adding a field to the table in the database.  It's just a plain text field, with no special properties.  The field was created one Server A, then using the "Copy" button in the "Manage Database" window, and was pasted pasted in to the corresponding table on the other server (I've don this many times before).

 

In my interface file, I then place the field (as a field, not a merged field) on the layout.  All good so far.  But here is where I break things.  If I change from using fmnet:/local.filemaker/database_name to fmnet:/remote.filemaker/database_name the field goes missing, literally "<Field Missing>".  If I then double click to reselect it, it has no concept of which TO it belongs to, or which field it represents.  I can however, select the correct field (which then displays the correct information).  By doing that, and then switching back, the field is now associated with a completely different field.  If I switch it back again, it starts the entire cycle over again.

 

Screen Shot 2016-08-08 at 12.39.06 PM.png

 

I can put other fields on to the layout, and they display correctly independent of the data source.

 

What strikes me as odd, if  I set up 2 additional data sources, 1 for each server, using the IP address (so 3 data sources pointing to the same file, with the same relationship) and add the field to the layout from those, they display the correct field and it's value.

 

I have verified that local.filemaker and remote.filemaker resolve to the correct IP address as putting the address in manually.

 

Both servers are running FileMaker Server 14 on Windows Server 2012r2.  Client is FileMaker 14 running on MacOS 10.11.6.

 

Any thoughts or advice would be greatly appreciated.

 

Thank you,

 

Michael Ramaley

Outcomes