14 Replies Latest reply on Aug 3, 2017 2:17 AM by KurtBleicken

    Web Direct is Turned off

    bimsickle

      I am still not able to get web direct working after it decided not to.

       

      All is enable on the admin console however going to the web address I get the message that it is turned off..

       

      I ran an Edit Deployment with the following results

      SETUP: PRECONFIGURE WEB SERVER

       

       

      Check to make sure FMI web site exists                      succeeded

      Create app fmi-test                                         succeeded

      Update WPE deployment configuration                         succeeded

      Enable/disable requiring secure connections                 succeeded

       

       

      UNDO EXISTING DEPLOYMENT

       

       

      Step 1: Unconfigure Web Publishing Engine (WPE):

      Stop WPE                                                    succeeded

      Set WPE AutoStart to disabled                               succeeded

      Update JWPC prefs file                                      succeeded

      Update WPE deployment configuration                         succeeded

      Step 2: Unconfigure web server:

      Update WPE deployment configuration                         succeeded

       

       

      START DEPLOYMENT

       

       

      Step 3: Save settings:

      Save administrative configuration settings                  succeeded

      Step 4: Configure Web Publishing Engine (WPE):

      Stop WPE                                                    succeeded

      Configuring JWPC memory                                     succeeded

      Set WPE AutoStart to enabled                                succeeded

      Add JVM Route to JWPC Server XML file                       succeeded

      Create CWPC prefs file                                      succeeded

      Update JWPC prefs file                                      succeeded

      Start WPE                                                   succeeded

      Update WPE deployment configuration                         succeeded

      Update mDNS service info                                    succeeded

      Step 5: Configure web server:

      Create IIS backup                                           succeeded

      Check to make sure FMI web site exists                      succeeded

      Create app fmi-test                                         succeeded

      Create worker properties file                               succeeded

      Enable proxy for Application Request Routing                succeeded

      Create Application Request Routing rules for Help           succeeded

      Create Application Request Routing rule for Web Publishing   message:New rule object missing required attributes. Cannot add duplicate collection entry of type 'rule' with unique key attribute 'name' set to 'BlockConf', , .

      Create Application Request Routing rule for Web Publishing  succeeded

      Allow X-Forwarded-Host header                               succeeded

      Add X-Forwarded-Host header                                  message:New add object missing required attributes. Cannot add duplicate collection entry of type 'add' with unique key attribute 'name' set to 'HTTP_X_FORWARDED_HOST', , .

      Create Application Request Routing action for Web Publishing succeeded

      Create Application Request Routing action for Web Publishing succeeded

      Create Application Request Routing match for Web Publishing succeeded

      And so on

      ....

       

       

      Could the two messages instead of results be why it isn't working??

       

      Create Application Request Routing rule for Web Publishing   message:New rule object missing required attributes. Cannot add duplicate collection entry of type 'rule' with unique key attribute 'name' set to 'BlockConf', , .

       

      Add X-Forwarded-Host header                                  message:New add object missing required attributes. Cannot add duplicate collection entry of type 'add' with unique key attribute 'name' set to 'HTTP_X_FORWARDED_HOST', , .

       

      I really would like to know how to resolve this as I have users that can only access over the web and it doesn't work.. Used to

        • 1. Re: Web Direct is Turned off
          TSPigeon

          bimsickle:

           

          Thank you for your post.

           

          You might start by trying the following:

          1. Uncheck "Enable FileMaker WebDirect" under Web Publishing > WebDirect

          2. Restart FileMaker Server

          3. Check "Enable FileMaker WebDirect" under Web Publishing > WebDirect

          4. Restart FileMaker Server

           

          If you are still experiencing the issue I would recommend a full uninstall and reinstall changing the FileMaker Server Folder Name (or removing it). It could be that some files with the installation are damaged. Sometimes software on the machine causes the damage, which might be prevented by adding the FileMaker Server Folder to any Exclusion/Exception lists with Security and Anti-Virus Software. You also want to verify no Third-Party software is backing up the Database Server folder while FileMaker Server is running.

           

          I hope this helps!

           

          TSPigeon

          FileMaker, Inc.

          1 of 1 people found this helpful
          • 2. Re: Web Direct is Turned off
            bimsickle

            Thanks Tspigeon.

            a uninstall and reinstall was the only thing that resolved the issue

             

            all working fine now.

            • 3. Re: Web Direct is Turned off
              sprynmd

              We are having the same problem.  Everything is working except WebDirect.  It was working after our recent upgrade from 14 to 15.  Re-deploying (and other efforts) did not help.

               

              So now we, too, have to do a full reinstall.

               

              ...Mike

              • 4. Re: Web Direct is Turned off
                bimsickle

                The reinstall was pretty painless, and everything was back to its former glory.

                 

                it wasn't as bad as I thought it might be, server was down for a half hour for the reinstall.

                • 5. Re: Web Direct is Turned off
                  sprynmd

                  Thanks for the encouragement, bimsicle.

                   

                  We've done several installs so I'm not concerned about the process.  Our issue is that we are a manufacturing facility with three shifts.  The FileMaker server is in use 24 hours a day and it affects people to take it down.  It's especially frustrating because we just did this a month ago to upgrade from 14 to 15.  Because it was a fresh install and WebDirect was working, our confidence level isn't that high that this re-install fix will be permanent.  A FileMaker tech support person suspects there are missing files now and the best fix is a fresh install.

                   

                  In any case, we have a planned down-time in order to reinstall this week.

                   

                  ...Mike

                  • 6. Re: Web Direct is Turned off
                    sprynmd

                    Well, it's happened again.  Web Direct stopped working.  The admin console says everything is fine, but we get the error message "Custom Web Publishing Technology disabled; WebDirect is turned OFF."  Turning Web Direct off then back on did not help.  Re-deploying did not help.

                     

                    We are currently on FMS 15.0.2.206.

                     

                    This will be so frustrating if we have to again kick everyone off to do another fresh reinstall to fix this.

                     

                    ...Mike

                    • 7. Re: Web Direct is Turned off
                      TSPigeon

                      sprynmd:

                       

                      If the issue has returned after any period of time, it may be due to something outside FileMaker Server's control. You may want to verify you have considered recommendation and best practices in the Getting Started Guide. Ideally you would want to be on a dedicated machine. Any Third-party backup software should not be touching any part of the FileMaker Server Folder except for Backups. Anti-Virus/Security software should have exceptions for the FileMaker Server folder and any components.

                       

                      FileMaker Server 15.0.3 is available, while I do not think it will help with this issue it is good to keep up to date.

                       

                      I hope this helps!

                       

                      TSPigeon

                      FileMaker, Inc.

                      • 8. Re: Web Direct is Turned off
                        sprynmd

                        Hi, TSPigeon!

                         

                        Thanks for the quick response.

                         

                        For what it's worth, we are on a dedicated virtual machine.  Our backup software (Veeam) is performing a system snapshot, not touching any files or folders.  I've been assured by our IT folks that the snapshot can have no affect at the file level.  No anti-virus software is running on the FMS machine.  We already had the 15.0.3 upgrade scheduled for next week.  The Windows server has auto-updates disabled.  We also have plans to upgrade the Windows server from 2012 to 2016 (maybe that will help).

                         

                        Last time FileMaker tech support said it looked like some files were missing and the best way to rectify it was to do a fresh install.  We're figuring that's the best approach again.

                         

                        ...Mike

                        • 9. Re: Web Direct is Turned off
                          TSPigeon

                          sprynmd:

                           

                          They may want to stop FileMaker Server before running these Snapshots.

                           

                          This post is a little older, but PhilModJunk and TSGal confirmed it was bad behavior to run a SnapShot on Live files: Hourly Image Snapshot / backup of server by Axcient-will it corrupt the Filemaker database on server

                           

                          Others say the Snapshots done on Live Files will require the "Live Files" to be replaced after a restore: Re: Safe to backup FMS live files with Windows Server 2012?

                           

                          I agree a reinstall is the way to get back up and running. You might prevent Snapshots from occurring while FileMaker Server is Live as well. If the issue still persists in the future then you can move on to other possible culprits.

                           

                          TSPigeon

                          FileMaker, Inc.

                          1 of 1 people found this helpful
                          • 10. Re: Web Direct is Turned off
                            sprynmd

                            TSPigeon:

                             

                            Thanks for the suggestions.  I will talk to the IT guys about that.

                             

                            ...Mike

                            • 11. Re: Web Direct is Turned off
                              stylish

                              Seriously? What a joke. We have the same issue here. REINSTALLING the product on the server is the only fix? FFS! There is no "repair" installation? Filemaker is "ok" with this as a solution?

                               

                              Any update for a REAL solution or are customers just expected to reinstall their server every few months??!!

                               

                              Thanks,


                              S

                              • 12. Re: Web Direct is Turned off
                                TSPigeon

                                stylish:

                                 

                                Thank you for your response!

                                 

                                If the issue persists or reoccurs after following the suggestions above I can gather some information from you for review. I am sending a private message to your inbox.

                                 

                                TSPigeon

                                FileMaker, Inc.

                                • 13. Re: Web Direct is Turned off
                                  TSPigeon

                                  stylish:

                                   

                                  I have reviewed the information you sent with Technical Support. Support should be reaching out to you soon.

                                  I also wanted to assure you that FileMaker's TSUsers are not Robots. We do read every response we come across in person.

                                   

                                  TSPigeon

                                  FileMaker, Inc.

                                  • 14. Re: Web Direct is Turned off
                                    KurtBleicken

                                    Having the same problem. Turned off WPE restarted the server, restarted and turned on WPE and no go.