ClausThiim

Bento to FileMaker 15 migration difficulties

Discussion created by ClausThiim on Aug 23, 2016
Latest reply on Oct 6, 2017 by TSGal

Sorry for the wall of text...

 

Up until last week I was happily using Bento 4.1.2 to log and track orders at work. Then I experienced issues in the Finder and in troubleshooting those issues, I was advised to 'move aside the Library' folder and then move back portions to see what was causing the actual issue in the Finder. Think back to troubleshooting extensions on MacOS9, same logic was at play.

 

In doing so, the Bento database was moved as well. After it was moved back to the active Library folder, Bento would launch and be stuck looking for the database. I checked the Library folder for the .bentodb file. All I found was an alias that referenced itself (a loop?). The actual document was nowhere to be found. Checking Time Machine was useless, just aliases in there, too going back months. Panicking, I tried restoring to the Bento backup made that morning. Bento still sat there, looking for a database. Checked the folder where the backups were archived, and found nothing but aliases dating back to December 31, 2014... everything earlier was a valid document, everything after was just aliases that referred to themselves. For a year and a half, my backups have been useless. I have no idea how or why this happened. I haven't needed to access a Bento backup so I was not aware.

 

With the help of a friend and Terminal commands, I searched for anything Bento-related that had been modified that day but found nothing relevant. I was using Bento that morning. I had entered data that morning. I'm baffled as to where or how Bento was storing the data if the main .bentodb document was apparently an alias as far as the Finder was concerned. It wasn't a recent event given that Time Machine had archived nothing but aliases of the database.

 

All I have left of my Bento database is an exported template document (.bentoTemplate) from about a month ago when I needed to extract data from Bento so someone else could access it. When I try importing the template, Bento just shows the progress bar. I’ve left it over the weekend with no success. I’ve tried on two separate computers (both on OS10.9, Bento 4.1.2, just like my primary iMac), with no success.

 

I have bought FileMaker Pro 15 and intend to use it instead of Bento. But I need my data.

 

I need my .bentoTemplate converted to a valid .bentodb file so I can run it though the ‘Bento 4 to FileMaker Pro Migration Tool’.

 

Can anyone help? I can send the .bentoTemplate to you…  

 

Thank you in advance.

Outcomes