6 Replies Latest reply on Sep 21, 2016 4:22 PM by bertrand

    FileMaker Pro 15, Applescript and Sierra

    bertrand

      Hello

       

      System : MacBook Pro (Retina, 15-inch, Late 2013) 16 GB memory SSD 500 GB

      Operating system : Sierra 10.12 Beta 5 (16A294a)

      FileMaker Pro : 15.0.1.119

       

      I know that Sierra is not a public version but it will be provided by Apple in some days and I've detect a problem with FileMaker and AppleScript.

       

      I use Applescript in FM solutions to switch printers or change setup for printer.

      Within El Capitan and FileMaker Pro 15 there is no problem but when using the same FileMaker files and Sierra, I got errors.

      A sub process launched when using Applescript crashes and report an error signal to FM which display a 1004 or 1005 error.

       

      You can see the errors in the joined file.

        • 1. Re: FileMaker Pro 15, Applescript and Sierra
          Benjamin Fehr

          Tried your example file.

          Exécution AppleScript

          I get result for

               MAC_Printer_default:     HP_LaserJet_CM1415fn__1F98C1_

           

          which meets current setup. No crash.

           

          I see we share almost same Hardware/OS specifications (MBP late 2013). Only difference I spotted is macOS10.12 beta 7  (16A304a) released last Monday!

           

          You might like to test with another AppleScripts as well as getting most current macOS beta:

          Send Message to AppleNotificationsCenter - ANC

          • 2. Re: FileMaker Pro 15, Applescript and Sierra
            TSPigeon

            Bertrand:

             

            Thank you for your post!

             

            I am currently unable to test on OS X 10.12 Beta, but I am going to move this thread from the FileMaker Community Feedback Space, which is specifically for input on the Community itself, to the Discussions Space where you should receive even more views and potentially more advice!

             

            TSPigeon

            FileMaker, Inc.

            • 3. Re: FileMaker Pro 15, Applescript and Sierra
              bertrand

              Hello Benjamin

               

              I work only with version beta 6 of masOS 10.12, not as developper.

               

              When I write the first post I worked with 10.12. 5 and now with 10.12.6, the result is the same.

               

              Bertrand

               

              Some informations for TSPigeon

              Copie écran 2016-08-29 à 16.56.58.pngCopie écran 2016-08-29 à 16.59.33.png

               

              Process:               FileMaker Pro [76980]

              Path:                  /Applications/FileMaker Pro 15 Advanced/FileMaker Pro Advanced 15.app/Contents/MacOS/FileMaker Pro

              Identifier:            FileMaker Pro

              Version:               15.0.1 (15.0.1)

              Code Type:             X86-64 (Native)

              Parent Process:        FileMaker Pro [72431]

              Responsible:           FileMaker Pro [76980]

              User ID:               502

               

              Date/Time:             2016-08-29 16:56:45.105 +0200

              OS Version:            Mac OS X 10.12 (16A304a)

              Report Version:        12

              Anonymous UUID:        1BA161D3-CCFD-AD3E-E26D-3DFDE26C71F3

               

              Sleep/Wake UUID:       136B0A06-E870-4D2E-9ECF-BD83425A9B53

               

              Time Awake Since Boot: 200000 seconds

              Time Since Wake:       1600 seconds

               

              System Integrity Protection: disabled

               

              Crashed Thread:        0  Dispatch queue: com.apple.main-thread

               

              Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)

              Exception Codes:       0x0000000000000001, 0x0000000000000000

              Exception Note:        EXC_CORPSE_NOTIFY

               

              Termination Signal:    Illegal instruction: 4

              Termination Reason:    Namespace SIGNAL, Code 0x4

              Terminating Process:   exc handler [0]

               

              Application Specific Information:

              BUG IN CLIENT OF LIBPLATFORM: Failed to allocate memory for string

               

              Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

              0   libsystem_platform.dylib      0x000000010847dc8b _simple_salloc + 122

              1   libsystem_malloc.dylib        0x00000001083b5a8e nanozone_error + 116

              2   libsystem_malloc.dylib        0x00000001083ab634 _nano_malloc_check_clear + 411

              3   libsystem_malloc.dylib        0x00000001083ab47b nano_malloc + 35

              4   libsystem_malloc.dylib        0x00000001083a4332 malloc_zone_malloc + 107

              5   com.apple.CoreFoundation      0x00007fff9a3495f7 _CFRuntimeCreateInstance + 295

              6   com.apple.LaunchServices      0x00007fff9b56a11e _LSASNCreate + 60

              7   com.apple.LaunchServices      0x00007fff9b56b9d1 _LSCopyFrontApplication + 103

              8   com.apple.HIServices          0x00007fff9913218f GetFrontProcess + 125

              9   com.apple.applescript         0x000000010f4d3f45 AEDefaultActiveProc(void*) + 46

              10  com.apple.applescript         0x000000010f4d8955 InternalComponentActive(unsigned int) + 81

              11  com.apple.applescript         0x000000010f50d51b UASRemoteSend(unsigned char, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char*) + 586

              12  com.apple.applescript         0x000000010f4e3c6c UASActor_Send(unsigned char, unsigned char, unsigned char) + 368

              13  com.apple.applescript         0x000000010f519089 UASValue_Send(unsigned char, unsigned char, TUASClassIndex, unsigned char) + 331

              14  com.apple.applescript         0x000000010f4ef521 UASExecute1() + 368

              15  com.apple.applescript         0x000000010f4ef35d UASExecute(unsigned char) + 192

              16  com.apple.applescript         0x000000010f4bd419 ASExecute(unsigned int, unsigned int, int, unsigned int*) + 451

              17  com.apple.applescript         0x000000010f4b92dc AppleScriptComponent + 1708

              18  com.apple.applescript         0x000000010f4d39e5 AGenericCall::Delegate(ComponentInstanceRecord*) + 37

              19  com.apple.applescript         0x000000010f4d39ab AGenericManager::HandleOSACall(ComponentParameters*) + 55

              20  com.apple.applescript         0x000000010f4d2fac GenericComponent + 172

              21  com.apple.openscripting       0x00007fff99cf548b OSAExecute + 65

              22  com.apple.Foundation          0x00007fff9bec678f -[NSAppleScript(NSPrivate) _executeWithMode:andReturnError:] + 131

              23  com.filemaker.client.advanced12 0x0000000103e10486 AS_ExecuteAppleScript(Draco::unistring const&) + 195

              24  com.filemaker.client.advanced12 0x0000000103fe49e7 ScriptRuntime::DoSendAppleScript() + 365

              25  com.filemaker.client.advanced12 0x0000000103fe1c91 ScriptRuntime::DispatchStep(bool&) + 2447

              • 4. Re: FileMaker Pro 15, Applescript and Sierra
                monkeybreadsoftware

                "Failed to allocate memory for string"

                 

                Did your FileMaker run out of memory?

                 

                 

                • 5. Re: FileMaker Pro 15, Applescript and Sierra
                  bigtom

                  10.12 is released. Same issue as beta?

                  • 6. Re: FileMaker Pro 15, Applescript and Sierra
                    bertrand

                    Christian Schmitz

                     

                    I don't think, there is a lot of memory free in macOS 10.12 and after this error FM continue to run. Each time, I use this kind of command, I get the same message.

                     

                    Bigtom

                     

                    I've downloaded macOS Sierra GM and the error is still here.