9 Replies Latest reply on Sep 1, 2016 9:02 PM by FabriceNordmann

    Import Field Data Error

    sportyguy209

      I can't figure out how to fix the following issue.

       

      The problem simply put is that I preview an import and I see unique data for all the records on the import side and after I import I get one record with different data than the preview. I would assume the data should import as it previews.

       

      So, if I am trying to import:

       

      1,2,3,4,5 I get 1,2,3,3,5

       

      I have attached a screen shot of the record that shows 56023 on the import preview, but when it gets imported it shows up as 59055 on the results side.

       

      Why would that happen and how can I fix it? Is there something that is corrupted?

       

      TIA

        • 1. Re: Import Field Data Error
          Johan Hedman

          If you have a import table to import your records to you can then Loop through your records and move data in a structured way that your solution need into your other table

          • 2. Re: Import Field Data Error
            David Moyer

            Hi,

            regarding the number of records, does the import show the same number of records as the source?  Are you importing FM->FM?  Or from another file?

            • 3. Re: Import Field Data Error
              Johan Hedman

              Do you have any Fields that you have validation on? If one of your validations does not match in your import, those records won't be imported

              • 4. Re: Import Field Data Error
                FabriceNordmann

                This is because you have some auto enter options in the field definition AND you checked the Perform auto-enters check box in the dialog after confirming the import order.

                In my opinion, this is a FileMaker issue, because you auto-enter options probably do not include a reference to self that would cause the field to reevaluate when modified. But… it's like that.

                The work around is: import just as you do now, and immediately after, import a second time only those fields (usually primary keys like in your example), choosing the second import type (Update existing record in found set), and of course do NOT perform the auto-enters.

                • 5. Re: Import Field Data Error
                  sportyguy209

                  Johan Hedman

                   

                  Yes, the original record is Auto-enter serial with Unique Value selected, but the imported record does not.

                  • 6. Re: Import Field Data Error
                    sportyguy209

                    David Moyer

                     

                    Yes FM to FM and yes, same number of records as the source.

                    • 7. Re: Import Field Data Error
                      sportyguy209

                      Johan Hedman

                       

                      The records are importing, just not all with the unique numbers in the source.

                      • 8. Re: Import Field Data Error
                        sportyguy209

                        1-more-thing

                         

                        This is because you have some auto enter options in the field definition AND you checked the Perform auto-enters check box in the dialog after confirming the import order.

                        In my opinion, this is a FileMaker issue, because you auto-enter options probably do not include a reference to self that would cause the field to reevaluate when modified. But… it's like that.

                        The work around is: import just as you do now, and immediately after, import a second time only those fields (usually primary keys like in your example), choosing the second import type (Update existing record in found set), and of course do NOT perform the auto-enters.

                         

                        I do have an auto enter option in an original field definition, but I'm not using Perform Auto-Enters after confirming the import order. In fact, I'm not getting that option.

                         

                        But, I tried the import with updating existing records in round set instead of updating matching records in found set and that worked! So, thanks for that suggestion!!!

                         

                        So, that option will work for me, but I'm still perplexed why the correct information shows up in the preview and doesn't end up getting passed through as I would expect. Seems to me that it should.

                        • 9. Re: Import Field Data Error
                          FabriceNordmann

                          The fact that you don't get the dialog where you can choose to perform auto-enters is consistent with not having auto-enters. Although I find it hard to believe (not calling you a liar! )

                          Is it possible that, even deactivated, there is an expression in the auto-enter calculation?