2 Replies Latest reply on Sep 22, 2016 1:21 PM by ontarget

    FM IOS SDK, iTunes Connect Issue

    ontarget

      September 20, 2016

       

      When I opened a new project that was added to the SDK folder, and I was trying to add it to Xcode I got a dialogue from Apple that I had to accept new terms related to iOS 10. I had no problem with the term so I agreed to them. But when I close the dialog I had another dialogue saying that I had update Xcode and install new products. Not seeing any issue that I completed the install. When I continued and opened Xcode, the install I just added change the version of my Xcode to version 8. This caused several errors to appear in the new project. Recently I added a discussion related to the same errors, and when I checked with support they indicated that version 7 of Xcode is the only accepted version of Xcode for the FileMaker SDK.

       

      Because of this issue, I was required to change the name of my project, and then rebuild the application again, and I had to create new provisioning profiles with a different name for the app ID and profiles.

      I also had to find an old version of Xcode 7.3, and I would use that version by opening it first and then running the SDK folder version to build the project in Xcode. All of this work just fine, and I was able to open the project in version 7.3 of Xcode and build the project and run it. This did not end the problem! I went back to iTunes connect where had created the prior project and I tried to create a new iTunes connect file for the new project. In the process of adding the new project, and adding data to the pop up screen I did not get the app ID to appear in the listed items for the bundle ID.

       

      I checked my profiles and my Apple ID, and everything looked correct. The only problem I had is that nothing I could do would allow my project to display a bundle ID in the dialogue I was viewing. Is anybody else run into this problem? If yes how did you solve it when the bundle ID is not displayed?

        • 1. Re: FM IOS SDK, iTunes Connect Issue
          ontarget

          For my discussion above, I had added this project and the information prior to having the issue explained above. I have tried several times after the application was not presented in the project list on iTunes connect to recover it. But I had no luck retrieving it after restarting iTunes connect several times. Three hours is going by, and I tried again and this time the application was displayed in the project list.

           

          It appears that Xcode was taken a day off at least the last three hours. But the application finally surfaced in the list. This doesn't answer the question why it didn't appear the first time?

          • 2. Re: FM IOS SDK, iTunes Connect Issue
            ontarget

            Sept; 22

             

            This issue has expanded in that when I updated to Mac Sierra on my iMac, what I thought fixed Xcode now reappeared. I'm using FileMaker 14 and the latest version.

            After updating my iMac to Sierra, I clicked on Xcode to do some work, and I got that same dialogue from Apple to update that started this whole problem. I tried to get out of the update canceling, but every time I open Xcode I get the dialogue again demanding me to update for new properties to be downloaded Xcode. Once I had to do this even version 7 of Xcode now produces errors for the FileMaker iOS SDK. I'm unable to load any project, because it will damage the project files by adding 29 errors. This occurs immediately after opening Xcode for any iOS SDK project. So essentially I'm unable to use Xcode until this is resolved.