9 Replies Latest reply on Jan 19, 2017 6:14 AM by MattLeach

    FM15 Long Delay Opening Hosted File

    MattLeach

      Since upgrading all clients to FileMaker 15, there is a noticeable delay when double clicking on a hosted file (hosted by FMS15). It can take up to 5 minutes for the logon screen to appear. Once the database has been opened at least once, if I close out and come back in it is substantially quicker so it appears it is only happening on the first logon of the day

       

      This has only happened since FM15, using FM14, the logon screen comes up in seconds opening the same file.

       

      Is this an issue with 15?

        • 1. Re: FM15 Long Delay Opening Hosted File
          BruceHerbach

          What OS is FMS and Pro running on?

          Are they connecting over Lan, WiFI or WAN?

          Did you check the server logs for network issues?

           

          Personally I haven't had this experience with 15 and 15 server.

          • 2. Re: FM15 Long Delay Opening Hosted File
            MattLeach

            FMS is running on Server 2008, nothing in the logs indicating network issues.

             

            FMP is running on workstations utilizing anything from Win 7 - Win 10 connected via LAN

            • 3. Re: FM15 Long Delay Opening Hosted File
              David Moyer

              Hi,

              just a thought - it sounds like it's trying to cache something huge.  I can only think of container storage as an issue.

              • 4. Re: FM15 Long Delay Opening Hosted File
                MattLeach

                The database in question consists of a single container field in which maybe 60 records have anything in it out of nearly 10,000 records.

                 

                The database does however have an external data source which is another FileMaker file that stores documents which contains roughly 80000 records with container data.

                • 5. Re: FM15 Long Delay Opening Hosted File
                  David Moyer

                  eh - 'twas just a thought.

                  Once you have it open, does it function normally?

                  • 6. Re: FM15 Long Delay Opening Hosted File
                    MattLeach

                    Yes, the delay appears to only happen during the first launch of the database.

                    • 7. Re: FM15 Long Delay Opening Hosted File
                      dtcgnet

                      In File>File Options, there is an option to "Switch to layout:". The order of operations when you open a file is: 1) Switch to the specified layout if that is selected THEN 2) perform the OnFirstWindowOpen script if there is one.

                       

                      When a file is hosted, it will always FIRST open on the layout which was the last layout used when the file was uploaded to the server. You may not even know which layout that is because the opening script usually has instructions to go to a certain layout. But if that initial layout is a list view with a summary field or something like that...you'll notice a delay that you can easily eliminate.

                       

                      I always use the "Switch to layout" option to guarantee that the first layout is a simple one (usually a form layout based on a table with no records), AND I have an opening script which runs OnFirstWindowOpen.

                       

                      Long story short...Go into File Options and select a simple layout to guarantee that you've selected a "low weight" opening layout. It's an incredibly easy performance booster to implement.

                      • 8. Re: FM15 Long Delay Opening Hosted File
                        MattLeach

                        The delay is happening before the login screen appears so I don't believe that would have any bearing in this particular case.

                        • 9. Re: FM15 Long Delay Opening Hosted File
                          MattLeach

                          I've been trying to tackle this issue since my original post and thus far have no concrete explanation or resolution.

                           

                          Over the past 3 months I have tracked the issue and its inconsistencies.

                           

                          The issues does not happen every day. Some days I can double click on a database to launch it and the login screen instantly appears. I can then logon and the database instantly opens. Other days, I double click on a database to launch and it could be anywhere from 1 minute to as much as 5 minutes before the logon screen appears.

                           

                          I have watched the performance monitor on the server to see if there is a spike in CPU, memory or disk usage and there is none.

                           

                          I have removed / reinstalled / updated the FileMaker client and there is no change.

                          I have removed / reinstalled / updated the FileMaker server and there is no change.

                           

                          At this point I don't know what else to do short of going back to using FM14 which did not experience this behavior.