1 2 3 4 Previous Next 45 Replies Latest reply on Nov 17, 2016 8:39 AM by scottworld

    Major bug with FileMaker Server 15: won't send email notifications after scheduled scripts, errors, or warnings

    scottworld

      We have discovered a serious bug with FileMaker Server 15.0.1.137 running on Windows Server 2012R2:

       

      FileMaker Server 15 will NOT send email notifications after any of our backup schedules are successfully completed, even though we have enabled "Email Notifications" for each one of our backup schedules (within each backup schedule's options). Furthermore, FileMaker Server 15 will NOT send email notifications after errors or warnings appear, either. In other words, FileMaker Server 15 won't send out any automated emails on its own at all.

       

      We have already successfully configured our SMTP settings in FileMaker Server under "General Settings > Email Notifications > SMTP Information", and clicking on the button enabled "Test SMTP Settings..." always results in successful tests to any email address that we can try sending to. We've clicked this button a dozen times, and everything works just fine. We have also checked the checkbox checked for "Warnings or errors" on the "General Settings > Email Notifications > Notification Settings" screen as well.

       

      However, FileMaker Server 15 is not sending out any automated emails on its own. None of these are being sent: (a) successful emails after an automated backup has completed successfully are not being sent, (b) warning emails are not being sent, and (c) error emails are not being sent.

       

      There are no typos in the single email address that we have specified within our scheduled scripts, and there are no typos in the single email address that we have specified in the the "General Settings > Email Notifications > Notification Settings" area. FileMaker Server simply isn't even attempting to connect to our SMTP server at all -- we can see this by looking at our "Sent Mail" folder on our SMTP server. There are absolutely no automated emails from FileMaker Server in our "Sent Mail" folder on our SMTP server. The only emails that actually appear within our "sent mail" folder are the ones which we manually sent by clicking on the "Test SMTP Settings..." button within "General Settings > Email Notifications > SMTP Information".

       

      So we can manually get FileMaker Server to send a test email by clicking on the "Test SMTP Settings..." button, but beyond that, FileMaker Server refuses to send any automated emails on its own.

       

      We are concerned about this for 2 reasons:

      1. We always want to know when our backup schedules are successfully completed. We had our Windows server freeze last week which prevented any of our backup schedules from running at all, so the LACK of an email notification will be a clue to us that something has failed with a backup schedule.

      2. We especially need to know when errors & warnings come up, to alert us to the bigger problems.

       

      Thanks,

      Scott

       

      TSPigeon  TSGal

        1 2 3 4 Previous Next