2 Replies Latest reply on Sep 28, 2016 1:22 PM by mr_scott

    Dead Records

    clind

      FileMaker Pro (all recent versions)

      Mac/Windows

       

      Dead Records: Example file attached. I have seen this problem several times over the past few years. A 'dead' records will show all blank values or all question marks. They are not editable, but will show up in finds. The mystery values appear to be very large. They were once normal records. It may have something to do with corrupt indexes. I cannot figure out how to fix the ones in the example file.

       

        • 1. Re: Dead Records
          mr_scott

          I ran 'Recover…' on the unzipped file and chose the 'Advanced' option, which found that the file has serious corruption issues. Lots of tables named 'Recover', and a 'Recovered Library' table. You may have to create a new file and build the schema from scratch to match each table - don't copy and paste, as that will just copy the damaged schema.

          Dead_Records-Recover_Summary.png

           

          Dead_Records-Manage_DB-Table_Details.png

           

          Dead_Records-Table-RecoveredLibrary.png

          • 2. Re: Dead Records
            mr_scott

            Hmm…The recovered file displays data, but the original shows "?". I ran the button script through debugger and saw it was sorting by the field named "Dat_e", then going to the first record.

             

            Not sure what I was supposed to find, but you may want to run 'Recover…' on your file, then open the recovered file to export all of the data, as it does seem to appear in the recovered file, but not your original.

             

            If your experience is different, I can attach the file I recovered to a future reply.

             

            Good luck!