nickorr

Updater shows false update with multiple copies of FMP installed

Discussion created by nickorr on Oct 3, 2016
Latest reply on Oct 6, 2016 by TSGal

Product and version FileMaker Pro 15.0.1 and 15.0.2

 

OS and version Mac OS 10.12

 

Description When you have multiple copies of FMP or FMPA advanced, the updater check gets confused and will show you an update dialog for an application that doesn't need updating.

 

How to replicate

 

Install two copies of FMPA 15.0.1 ( I duplicated one installed app folder completely ).  Open copy 1 and check for updates.  It notifies you about 15.0.2 being availble, download and install it.  Then check for updates again in the updated copy 1.  It now says you're running 15.0.2 and there's an available update to 15.0.2 and you should install it ( see dialog ).  Quit and open Copy 2 and check for updates.  The dialog is correct.

 

Workaround You need to run both updaters separately.  I didn't check what would happen if you re-ran the update for the copy that was already up to date.

Outcomes