12 Replies Latest reply on Dec 28, 2016 9:27 AM by TSGal

    PDF will not save (scripted or manually) in FMPA 15.0.2.220

    DSKatSCL

      Product and version Client = FileMaker Pro Advanced 15.0.2.220, Two different Servers = 14.0.4.412 and 15.0.1.137

       

      OS and version Windows 7 Enterprise SP 1 64 bit

       

      Hardware  32 MB RAM

       

      Description I just upgraded to 15.0.2.220 since I last ran this report. Both scripted and manual attempts to save as a PDF fail on a report that has been working flawlessly for over two years in previous versions.  I have a text-based report with the following sections; Header, Leading Sub-Summary, Body, Trailing Sub-Summary, Trailing Grand Total, and Footer.  There is colored text throughout.  If I try to save it as a PDF (scripted or manually), I get the following error dialogue box show up: "["report name"] could not be created on this disk.  Use a different name, make more room on the disk, unlock it or use a different disk." The script goes on to append a graphic section of the report to the text based report and this part saves without any issues to the same folder on the same drive.  I then tried to save the text-based report manually and I get the same error.  I then opened the solution in FMP version 14 and ran the script.  Ran perfectly, and saved the text-base portion and then appended the graphics-based portion without any issues.  So, I know it is not a drive issue, but seems to be something that has been changed in version 15.0.2.220, since the previous version work just fine.

       

       

      How to replicate

      1. Tried saving a different layout that has the same section format, colorization, and more fields and it fails also.
      2. Tried to remove objects, sections, conditional formating from the original layout.  Nothing seems to help.
      3. Moved to my 15.0.1.137 test server and I get the same error message.

       

      Workaround Rolled back to FMPA 15.0.1.119 and the script and manual saving as a PDF work fine.