1 2 Previous Next 26 Replies Latest reply on Jan 17, 2017 10:36 PM by CICT

    Save as PDF Error

    ktipson

      I am using Filemaker Pro 15.02.220 (upgraded to the most current version yesterday).  Today when I try to save something as a PDF, I get an error message that says " PDF could not be created on this disk.  Use a different name, make more room on the disk, unlock it or use a different disk." Any ideas what's causing this?

        • 1. Re: Save as PDF Error
          longball22

          It could be one of a number of things. The most common being:

          • The name of the PDF file you are trying to save as could contain bad characters. (Saving a file with a "/" in the name can cause issues.)
          • The location where you are looking to save could be typed wrong or be non-existent.
          • 2. Re: Save as PDF Error
            philmodjunk

            There is a known issue with saving PDFs from FMP 15, both before and after the recent update. Just doe some searching here and you'll see a number of other posts by people complaining of the same issue.

            • 3. Re: Save as PDF Error
              ktipson

              I get the error no matter what the file is called and no matter where I try to save it on my computer.  This also wasn't happening up until a day ago.  The only thing I changed was upgrading to the latest version of Filemaker.

              • 4. Re: Save as PDF Error
                ktipson

                SOLUTION: Create a button on a layout and assign it a single-step "Save as PDF."  Use the button (it should successfully create a PDF).  Then try to do the same function from the menu- again it should successfully create a PDF.  This seems to have solved the problem. 

                • 5. Re: Save as PDF Error
                  ktipson

                  I celebrated too soon.  The problem went away this morning and then I tried to do it again this afternoon and the old error returned.  No idea what could have possibly changed between this morning and this afternoon. 

                  • 6. Re: Save as PDF Error
                    JLowden

                    I just upgraded to FM15 and am also getting an error when saving as PDF.   Error 800, unable to write to disk.   This happens with old scripts that use a $variable.  It happens with scripts that have dialog on to prompt user to name file and save.  And it also happens using the Save as PDF command from the File menu.   I opened the same files using FM14 and everything works correctly - all scripts work fine.

                     

                    I am about to do FM15 upgrades with several clients, but this is a major bug.  Any update on this problem?  I am on Windows 10.

                    • 7. Re: Save as PDF Error
                      cjurdaneta

                      I already has the same problem, i change all the extensions of my fonts in my layouts TTF to ttf.

                      And then works ok.

                      Try with Arial Family fonts and all , and try with one form all in arial.errorpdf1.jpg

                      • 8. Re: Save as PDF Error
                        JLowden

                        Hmm, I have dozens (maybe hundreds) of layouts in my solutions that are saved as PDFs.  I will give this a try, but it is not a reasonable fix for me (charging my clients by the hour for such is a fix is not fair to them).   But thanks for the suggestion, I am willing to try anything right now.   Cheers, Joan

                        • 9. Re: Save as PDF Error
                          JLowden

                          I fear you are correct - I was just able to save a very basic layout that uses Arial as PDF.   Arghh, that is alarming that the fonts are causing the Save as PDF command to fail.   Years of layouts and scripting won't work with FM15????

                          • 10. Re: Save as PDF Error
                            cjurdaneta

                            In my opinion is an error of FM15, they need to solve in the next release, but meanwhile there to keep using the programs that you have using.

                            1 of 1 people found this helpful
                            • 11. Re: Save as PDF Error
                              ktipson

                              Can you give me more guidance on how to change to .ttf?

                              • 12. Re: Save as PDF Error
                                cjurdaneta

                                You need to go to disk C, then open the folder Windows and then the folder fonts.

                                You touch each font of a family like Arial and the right botton , touch properties and the upper

                                you see ARLRDBD.TTF  CHANGE to ARLRDBD.ttf

                                 

                                And all fonts that you use in your layouts you need to change.

                                 

                                The format TTF is old and the ttf is the new one, probably in the new Filemaker 15 dont use TTF.

                                1 of 1 people found this helpful
                                • 13. Re: Save as PDF Error
                                  ktipson

                                  My control panel doesn’t give me the option to change it.  I mainly use Century Gothic in my Filemaker layouts and this is what I see when I select Properties on the font:

                                   

                                  • 14. Re: Save as PDF Error
                                    JLowden

                                    I can't see how to change the extension either.  Some of the fonts don't even let me view the properties, and I can see where some fonts are TTF vs. ttf, but I can't edit the extension.    Since most of the fonts I use are built-in (Tahoma, Verdana, Times New Roman, etc) it shouldn't cause a problem.   I'm still playing with different things to see what might work.   Filemaker - any response to this????

                                    1 2 Previous Next