1 Reply Latest reply on Oct 17, 2016 1:30 PM by TSGal

    Strange Reporting Behaviour

    milton.kirkwood@gmail.com

      Hi All,

       

      With the recent upgrade to Filemaker 15 Advanced Pro (Ver 15.2.2.220) which is currently running on my 15" MacBook Pro Retina display (Mid 2012) with OSX 10.11.6 (El Capitan) with 16 GB of RAM I have started to notice some unusual behaviour.

       

      I have a commercial application running hosted with FMP Host but the behaviour occurs whether I run it in the Cloud or on my laptop. Reports which were previously running correctly now start to miss records. I have a parent CLIENT table and a child PROJECTS table linked on the CLIENT ID unique index field. For the report I select records from the PROJECTS table based on three selection criteria. Of the selection fields two are binary and the third is a date field which I compare against the current date using Get(CurrentDate).

       

      I had a similar problem with another report, based on the same two tables and the only way I was able to fix the problem was to recreate two CLIENT entries and their linked PROJECTS. Once I had done this the report worked okay.

       

      Has anyone else noticed similar strange behaviour with reports?

       

      Thanks,

       

      Milton

        • 1. Re: Strange Reporting Behaviour
          TSGal

          milton.kirkwood:

           

          Thank you for your post.

           

          I have not seen this manifestation previously, and I realize that doesn't help you.

           

          Do you see this issue immediately?  Or, does this occur after an extended period of time?

           

          With these records that are "missed", do you notice if the records are recently entered or if the records are old, or if the records are random?

           

          If you create a new layout with a new portal displaying the same records, does the issue still occur?

           

          In essence, I'm trying to determine if something changed in the file either with the data or the layout.

           

          Run a Recover (File -> Recover) on the file and see if any errors are reported.

           

          TSGal

          FileMaker, Inc.