7 Replies Latest reply on Mar 16, 2017 8:28 AM by alecgregory

    Modifier keys BROKEN in 15.0.2

    jrenfrew

      Oh my how I beat myself in the head till I discovered this is a repeatable issue in the latest 'fix' release

       

      Mac on both 10.11 and 10.12

      FMPA versions from 14.0.3 to 15.0.2

       

      Create a simple script

      custom dialog with the body Get ( ActiveModifierKeys)

       

      In all version EXCEPT 15.0.2 you will see 2 in the dialog when the short key is pressed, in the newest version you see 0. that's right 0, so alter navigation I am just building will not work to redirect to another layout based on a modifier key.

       

      Created file and taken it round all the  machines in the office, and it is ONLY problem in 15.0.2, but that means this update can not be installed, leaving all the other fixed thing broken

       

      Try with this file..

        • 1. Re: Modifier keys BROKEN in 15.0.2
          TSPigeon

          jrenfrew:

           

          Thank you for your post!

           

          I was unable to reproduce this behavior with FileMaker Pro 15.0.2 (Advanced) on OS X 10.12. I used your demo, pressing the button while having Active Modifiers pressed. I experienced in the dialog:

          When shift is held = 1

          Whens Caps was enabled = 2

          Ctrl = 4

           

          Verified FileMaker Pro 14.0.6 returns the same values. Would there be anything I am missing to reproduce?

           

          TSPigeon

          FileMaker, Inc.

           

          Screen Shot 2016-10-14 at 3.01.31 PM.pngScreen Shot 2016-10-14 at 3.10.31 PM.png

          • 2. Re: Modifier keys BROKEN in 15.0.2
            TSPigeon

            Holding shift:

             

            Screen Shot 2016-10-14 at 3.14.23 PM.png

            • 3. Re: Modifier keys BROKEN in 15.0.2
              TSPigeon

              I did find a case where a program called "Webroot" caused this issue. I wonder if you could be seeing something similar?

               

              TSPigeon

              FileMaker, Inc.

              • 4. Re: Modifier keys BROKEN in 15.0.2
                jrenfrew

                Thanks for testing...

                Turned off Mac and it then needed a hard reset to turn back on again so there was clearly something else going on. Except not worked in 14 on the same machine.

                 

                Only thing I can think of is latest Flash update and the browser hadn't been restarted all day.. Not sure how that might affect this though.

                • 5. Re: Modifier keys BROKEN in 15.0.2
                  jwmickelson

                  Just to help expose this information better (as it took me a long time to find this comment), we ran into this issue where modifier keys stopped responding on our Macs.  We recently had a Webroot installed for security... there is a setting called secure keyboard, which somehow interfered with the OS and FileMaker's access to the value for the modifier keys.

                   

                  Below is a cross paste of the relevant info from (Get active modifier keys broken in FMP14 ), to help anyone else that runs into the same problem and also has Webroot:

                  ----------------------

                  SOLVED : this was not a FileMaker Issue.  This was an issue with a program called Webroot.  It is a Mac security program, and it has a feature called "Secure Keyboard Entry" which when disabled allowed Modifier Keys to work.  So the problem was probably between this program and the OS and how the OS passes keyboard data to FileMaker.

                   

                  Below is a screenshot of how I temporarily disabled the feature for testing:

                   

                  Below is where you disable the offending feature for good:

                   

                  Hopefully this helps anyone else that has Webroot installed (it's not a bad app, just has a feature that can interfere with FMP).

                  • 6. Re: Modifier keys BROKEN in 15.0.2
                    jwmickelson

                    Hi jrenfrew, I'm hoping your issue is resolved by now ;(

                     

                    But just in case it came back up, I wanted to let you know that my issue looked very similar to what you reported and was indeed caused by Webroot, it's a security suite for Mac's.  It may be worth checking out, to confirm you don't have it installed.

                     

                    Best,

                    Jonathan

                    • 7. Re: Modifier keys BROKEN in 15.0.2
                      alecgregory

                      I am also seeing this issue in FileMaker Pro Advanced 15.0.3.305.

                       

                      I think it may be related to the script debugger. It tends to crop up when I'm debugging. The only fix I've found is the hard reset as you described.