1 Reply Latest reply on Oct 17, 2016 2:44 PM by wadecaldwell

    Mac 10.11.6 Security Update 2016-001 breaks FMS WPE and FSE

    wadecaldwell

      I was doing normal server maintenance this morning on my Mac Mini that functions as my standalone FM Server machine and ran the Security Update 2016-001. It was a minor security update, so I didn't pay much attention to it until it started running and it was taking 10-15 minutes to install and restart the machine. As soon as it finished and came back up, all of my database-driven websites went down. Of course, since it was a minor security update, I didn't stop to do a full current backup (won't make that mistake ever again). When I went to sites, there was a php error that said out of memory. Launched FMS admin says that the WPE and FSE terminated abnormally. Database server is up and running fine. Seems to have only affected those two components. Haven't found any reference to this issue so far, but lots similar and lots related to this particular security update. I am not running Mac Server on this machine, so I don't believe it is related to the security update taking over port 80.

       

      So far, I have tried:

       

      1) run Repair Permissions - no resolution

      2) updated FMS from 15.0.1 to 15.0.2 - no resolution

      3) found security update problems on apple discussions that were solved by removing folders inside /private/var/folders and then restarting - no resolution

      4) localhost shows FM Database Server home page, so the port issue doesn't seem to be the problem. ran command line call i found here that turns off mac web server, just in case i was missing something, but it didn't find anything.

      5) spent a long time on apple tech support trying to find out any details on the update as to what could have caused FMS issue

      6 talked to apple and there is no way to go back to 10.11.6 prior to the security update as all updaters have those security features included.

      7) determined the next course of action was to upgrade a backup disc of the Mac Mini to 10.12 Sierra and see if the new OS solves the issue - no resolution

      8) Talked to FM tech support and determined the next course of action is a complete reinstall of FMS. The update must somehow have corrupted  FMS 15 in some way.

       

      I'll post the results once I do the reinstall.

        • 1. Re: Mac 10.11.6 Security Update 2016-001 breaks FMS WPE and FSE
          wadecaldwell

          Resolution: Portions of FMS15, SuperContainer and MirrorSync were evidently all corrupted/broken by the Security Update. I ended up doing a full uninstall of FMS 15, a complete reinstall and deployment of FMS 15.0.2 onto OS 10.11.6, followed by reinstalls of SuperContainer and MirrorSync. Everything is back up and running after 10 hours.

           

          Lesson - even for simply described Apple security updates to an FMS server machine, create a SuperDuper clone before you start so that you can recover and not lose time rebuilding. This security update ending being rather large and involved and evidently did a bunch of stuff under the hood.