0 Replies Latest reply on Oct 19, 2016 5:07 PM by mardikennedy

    Layout corruption

    mardikennedy

      FMPA 15.02, client environment is Windows 7; *dev file only*, hosted on test server install of FMS 15/ Mac OS 10.11.6.  The file was originally created in FMPA 14, maybe 12 months ago.  Not particularly complicated - not a lot of layouts, scripts, fields, tables, relationships and no custom functions.  Custom theme.  Most of the development was done on a local (Windows) machine, as the test server install only recently became available.

       

      Recently (?several weeks ago), it became apparent that several layouts looked 'weird' in layout mode and could not be resized at all.  (There were two vertical margin/ borders rather than one, the first approx. at 600 px and the second at approx. 1200 px, for what it's worth.)

       

      I tried creating new layouts, both with the file's custom theme and alternative 'standard' ones, and all new layouts displayed the same issue.

       

      I sent a clone to FMI who confirmed that the layouts were corrupted and that it would be best to recreate them, not, of course, using copy and paste.  Given that all new layouts exhibit the behaviour, that was not functionally possible.  Thereafter I ran a Recover, and after reporting that no problems were found, the Recovered file looked and behaved completely normally, ie no more unresizeable layouts.

       

      This is the question:

      Has anyone else had similar experiences?  Which FMP version(s)?  Any other observations that might be relevant, ie might make the experience 'predictable'/ avoidable?

       

      I don't know if it's related to this thread:  corrupted layouts and objects

       

      With kind regards,

      Mardi