2 Replies Latest reply on Jan 16, 2017 8:53 AM by ClickWorks

    IOS 10 FMP parameters aren't properly passed to FM GO 14 and 15

    ClickWorks

      Filemaker GO 14.0.4 and 15.0.2

      IOS 10.0.2

      iPad Air 2

       

      Description: When opening a FM GO app through a link with the FMP protocol on IOS 10, the app opens correctly but none of the parameters are passed to the app.

       

      URL format: fmp://<<ip adress>>/<<Host app>>?script=download&param=<<FM go app>>[<<USER>>|<<First name>>%20<<Last name>>]

       

      Until before the update to IOS 10 this worked perfectly on my iPad. This issue appeared as well on an iPhone running IOS 10, while it worked fine on IOS 9. While the exact same link works for iPads running IOS 9.

       

      How to replicate: Update to IOS 10, launch a FM GO app through a FMP link with a script and pass a parameter to the script. Make sure this parameter becomes visible in the app: eg. set field. Once the app opens all parameter seem to be empty.

        • 1. Re: IOS 10 FMP parameters aren't properly passed to FM GO 14 and 15
          TSGal

          ClickWorks:

           

          Thank you for your post.

           

          I am unable to replicate the issue using an iPad Pro under iOS 10.0.2.  Here are the steps I took:

           

          1. I created a file, 1o.fmp12, with one Text field "F1".

          2. I created a script, "Remote", with the following two steps:

              Set Field [ Table::F1 ; Get ( ScriptParameter ) ]

              Commit Records/Requests [ With dialog: Off ]

           

          3. In Browse mode, I added one record.

          4. I created a second file, 1oStart.fmp12, with no fields.

          5. In Layout mode, I created a button that executed a Simple Step:

              Open URL [ With dialog: Off ; "fmp://<IP Address>/1o.fmp12?script=Remote&param=1"

           

          6. I turned on Network Sharing for both 1o.fmp12 and 1oStart.fmp12.

          7. From my iPad, I opened the hosted "1oStart.fmp12" using FileMaker Go 15.0.2.

          8. I clicked the button, 1o.fmp12 opened, and "1" was put into the field "F1".

           

          Does your issue only occur with a specific file?  That is, are you able to pass a parameter to a different file?

           

          TSGal

          FileMaker, Inc.

          • 2. Re: IOS 10 FMP parameters aren't properly passed to FM GO 14 and 15
            ClickWorks

            The issue has been solved, the problem was that the last character of the URL ( the "]" ) wasn't recognised as a part of the URL in IOS 10.

            This resulted in a missing parsing character in our parameter. The FMP protocol works fine and there is no issue with FM GO.

             

            Thank you for your time and feedback,

            ClickWorks