5 Replies Latest reply on Nov 2, 2016 10:11 AM by Fred(CH)

    CSV format unsupported on some Countries

    Fred(CH)

      Product and version

      FileMaker Pro 15.0.2 and ALL prior

      OS and version

      Mac and Windows

      Hardware

      Not relevant

      Description

      FileMaker Pro only support US-like CSV format conversion; However, in some countries as France for insance, the CSV files are generated with the semi-column separator, so the actual CSV conversion feature available on FMP Import, Export and Open command is unusable on these countries.

      See also the following wikipedia article (in french) under § "Variante française" :

      Comma-separated values — Wikipédia

      How to replicate

      If you try to create a CSV file form Excel for instance with french localisation settings, you will see that the separator is not comma but semi-column; If you then try to import this file in FileMaker Pro, you will see that the column are not correctly separated.

      Workaround

      For the import / Open commands : Open the file with Excel and convert if to txt (tab separated).

      For the export command : Open the file with a text editor and replace all the following 3 digit strings "," by a ";" new one.

        • 1. Re: CSV format unsupported on some Countries
          TSGal

          Fred(CH):

           

          Thank you for your post.

           

          Our Development and Testing departments are aware of this issue.  Currently, the CSV (comma-separated values) will only accept commas.  However, if you use Merge (Mailing) option, this will accept semi-colons as the separator.

           

          I have attached your post to the original report.  When more information becomes available, I will post again.

           

          TSGal

          FileMaker, Inc.

          1 of 1 people found this helpful
          • 2. Re: CSV format unsupported on some Countries
            Fred(CH)

            TSGal,

             

            Thank you so much for this confirmation and of course for the workaround !

             

            Fortunately, I was able to apply this workaround on Windows platform. However, i was not able to do so on macOS.

             

            In essence, sounds like FileMaker Pro is using the system definition of "List separator" located on Windows regional settings; however, i was not able to find this specific setting as a part of macOS's language and regional panel.

             

            Can you confirm this information ?

             

            Big thanks once more...

             

            Fred

            • 3. Re: CSV format unsupported on some Countries
              Louis A. Voellmy

              Hi Fred

              Using the BaseElements PlugIn I was able to create a script-based export in a «correct» CSV format for the canton of Zürich to be imported into their website. It was even possible to declare which Text-Encoding to use.

              Kind regards

              Louis A. Voellmy

              1 of 1 people found this helpful
              • 4. Re: CSV format unsupported on some Countries
                TSGal

                Fred(CH):

                 

                The workaround appears to work for me under macOS Sierra 10.12.1.  When using FileMaker Pro 15.0.2 under macOS Sierra 10.12.1 (United States), the Merge file format exports with commas.  When I switch System Preferences -> Language & Region settings to French (Preferred languages and Region), launch FileMaker Pro 15.0.2, and export using the Merge (Mailing) file format, I do get semi-colons.

                 

                Are you using French or another language?

                 

                TSGal

                FileMaker, Inc.

                • 5. Re: CSV format unsupported on some Countries
                  Fred(CH)

                  I used french but was trapped by the region parameter, for testing I set the language to "French (France)" but i disregarded that this leave the Region field as "Switzerland" which was obviously the key, my fault...

                   

                  Set the region to "France" did the trick...

                   

                  Thanks a lot for your support !

                   

                  Capture d’écran 2016-11-02 à 18.10.23.png