9 Replies Latest reply on Nov 4, 2016 10:52 AM by TSGal

    Runtime solution Send Mail SSL Error

    jtu

      Product and version FileMaker Pro Advanced 15.0.2.220

      OS and version Windows 7 Professional 64-bit SP 1

      Hardware Dell laptop, Intel i7-6500U, 8 GB memory

      Description Send Mail via SMTP works fine from within FMPA but fails in a stand-alone. Error message in stand-alone is "There was an error with SSL."

      How to replicate Send Mail [Send via SMTP Server; No dialog]; Port 465; SSL; Plain Password

      Workaround none found so far

       

      I have replicated this error on multiple machines and logging in with both Administrator and data-entry-only access. Seems very similar to the issue efficientbizz mentioned in May (Send Mail [Send via SMTP] with SSL Error ). Wondering if there is a solution since none was mentioned in that post. I unfortunately don't have the time (doing a demo at a conference next week) or technical ability to implement the work-around mentioned there.

        • 1. Re: Runtime solution Send Mail SSL Error
          TSGal

          jtu:

           

          Thank you for your post.

           

          This appears to be the same issue as what was reported by efficientbizz.  Are you also using gmail server?  If so, instead of using SSL and port 465, what occurs if you try using TLS and port 587?

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Runtime solution Send Mail SSL Error
            jtu

            Thanks for the quick response! We are using FastMail. It allows for TLS and port 587, and that works within FMPA, but I still receive the same SSL error in the stand-alone.

            • 3. Re: Runtime solution Send Mail SSL Error
              Benjamin Fehr

              maybe you wanna explain your user case with sending Emails though chances are that we'll find a work around.

                   Send Email [via Mail Client]      instead of smtp

              should work.

               

              I have a user case were "Send Email" is used for password activation process. Customers send SW-Activation request to my email account.

              See a raw description of my work around in this thread:

              Send Mail [Send via SMTP] with SSL Error

              • 4. Re: Runtime solution Send Mail SSL Error
                TSGal

                jtu:

                 

                Thank you for the additional information.

                 

                Although I am unfamiliar with FastMail, are you trapping for any error message from within the Runtime app?  If so, what is the error number captured?  Or, do you just get the message "There was an error with SSL"?

                 

                Do you have access to a Mac?  If so, does the issue also occur?

                 

                TSGal

                FileMaker, Inc.

                • 5. Re: Runtime solution Send Mail SSL Error
                  jtu

                  Yes, the issue also occurs on a Mac.

                   

                  I've done some additional testing, and the error only happens with the combination of a runtime solution in kiosk mode. A kiosk solution on its own is fine, as is a runtime solution.

                   

                  I set up error trapping and a dialog box to report the error number. Running within FMPA, where the Send Mail works, the error number is of course 0. In the runtime kiosk version, the dialog box doesn't even open. I'm new to FM - here are the script steps in case I've done something wrong:

                  Set Error Capture [On]

                  Send Mail [Send via SMTP, etc...]

                  Show Custom Dialog ["Error"; Get(LastError)]

                   

                  Also, the runtime solution's log file shows nothing.

                   

                  For now, a runtime solution is the only practical way to go. I was counting on using the kiosk mode to keep interaction as simple as possible for the end user, but I may see if I can manage security and other settings to get close to the desired experience without kiosk mode. That said, if there is a way to have Send Mail work in a kiosk-mode runtime solution, I would love to know.

                   

                  Thanks!

                  • 6. Re: Runtime solution Send Mail SSL Error
                    jtu

                    Thanks for the response, efficientbizz! I'm bummed by this little roadblock because the app I'm building turns a 30-minute process into a 3-minute one. Having the email sent from FileMaker via SMTP is literally a push-button process - very slick and easy, in keeping with the rest of the app. I'd love for it to just work the way it's supposed to. As I mentioned to TSGal, Send Mail does work as long as the runtime solution is not created using kiosk mode. I will pursue that for now and see if it beats the alternative of sending via the user's email client (which, I have to say, I had some issues with when I tried it, maybe because of kiosk mode wanting to have control of the whole screen(?) - but I didn't spend much time trying to diagnose).

                    • 7. Re: Runtime solution Send Mail SSL Error
                      TSGal

                      jtu:

                       

                      Thank you for the detailed information.  I have sent all information to our Development and Testing departments for review.  When I receive any feedback, I will let you know.

                       

                      TSGal

                      FileMaker, Inc.

                      • 8. Re: Runtime solution Send Mail SSL Error
                        jtu

                        Hey, TSGal, it looks like I made a mistake in my testing. I've gone back through everything again, and it looks like none of the runtime solutions are able to Send Mail. I think what happened was that I had error trapping in a version where I didn't realize it, and that prevents the SSL Error message from appearing; and a little while after running it I received an email that I thought was from that test run. In fact, it must have been a delayed receipt from one of my earlier test runs. I have re-run every stand-alone with a better way to identify which .exe generates the email (if any) that is received, and I have verified that none of the ones created as runtime solutions are able to Send Mail. My sincere apologies for the confusion.

                         

                        The kiosk-only solutions are fine but unfortunately are not viable for our business needs.

                        • 9. Re: Runtime solution Send Mail SSL Error
                          TSGal

                          jtu:

                           

                          Thank you for the correction.

                           

                          As it turns out, Testing has said this issue is the same issue reported by "Benjamin Fehr" earlier (see his link above).  Your posts have now been attached to the original report.  When more information becomes available, I will post again.

                           

                          TSGal

                          FileMaker, Inc.