Vincent_L

Filemaker Pro 15v2 client stuck after lengthy script

Discussion created by Vincent_L on Nov 9, 2016
Latest reply on Dec 5, 2016 by Vincent_L

Hi,

 

2 days in a row I encountered  this issue :

 

I ran a very lengthy script (12 hours) from a client of a FMS 15v2 hosted solution. The morning the  Filemaker client was said to be non responding in activity monitor.

 

The first day, by putting frontmost and in background the client app, several times, it eventually resumed ok.

 

The next day, I went back to this client in the afternoon (so the client may have been stuck much longer).

 

Suspecting a locking issue (what else could this be), in the evening I disconnected all the other clients, and tunred off server side script.

But the Filemaker Client never resumed.

 

Please note that CPU usage of the "non responding" FMP Client was 0%

 

So I sampled the client process, you'll find it in the dropbow archive below. Also, I attached all the entire server log folder.

I tried to use the top call stats, but it showed nothing from this client.

 

Dropbox - filemaker_client_stuck_for_18hours.zip

 

Could you tell me, why it was stuck ?

 

Thanks

Best regards,

Vincent

 

 

 

 

 

P.S : Server and client on Sierra 10.12.0

Outcomes