AnsweredAssumed Answered

Filemaker Server not releasing client connections, locking record

Question asked by jevans88 on Nov 9, 2016
Latest reply on Nov 20, 2016 by Johan Hedman


Filemaker Server not releasing client connections


FileMaker Server



Operating system version

Windows Server 2012 R2, clients are using iPads and iTouches Filemaker Go 15

Description of the issue

When clients log off, server status still shows connected clients and open databases.  Over time, clients are listed multiple times (4-6 or more) The clients will go away when selecting 'disconnect client' but the system still acts as if they are connected and will not allow records to be edited/saved saying they are locked because they are still in use by 'client x' The physical server must be restarted to fix the problem. Even restarting the Filemaker Server software still results in the records being locked and multiple connections quickly show up again. After the restart of the physical server everything works fine for awhile, sometimes a few days, but usually at the most for less then 24 hours before the same symptoms start up again.

Expected result

After the designated time-out setting, the server should release the old client connection and the db's showing open for that connection.  OR  The server should re-use the old connection for the user rather than opening a new one.

Actual result

If the server is not restarted, after all users are gone and off the system, 1/2 of the users are still listed multiple times, and the the records that need to be saved are locked.

Exact text of any error message(s) that appear


Configuration information

Most mobile users are on the local network.  Filemaker server has an odbc connection to MS SQL Server on same local network.  Most db's opened and used by users have sql tables in them.


Only restarting the physical server on which FMS is installed.


This is driving me crazy! If anyone can help or point me to someone who can I would really appreciate it. I have been dealing with this issue for months.