12 Replies Latest reply on Jan 24, 2017 1:36 PM by user10625

    Filemaker Server 15 installation won't get started

    user10625

      On  Windows Server 2008 R2 SP1.

       

      Un-installed Filemaker Server 14.

      Cleared the JAVA and Web Browser Caches.

      Rebooted.

       

      Double-clicked the Server Install icon, and it began to do it's thing. 

      The command-line window briefly appears and then . . . .

      Nothing. Just quits.

      Did not even get to the License entry part of the installation.

       

       

      We already had a working FMS 14, so AFAIK all of the web ports, firewall, and etc. are set up properly.

      No antivirus, etc.  As far as I can see (double-checking the Getting Started Guide),  the server is all set up properly.

      Also, the machine was able to see the internet, so anything that needed to be downloaded should have been fine.  (I double-checked this by doing some googling in a browser).

       

      Any reason why this would be happening? 

      Is there any way to run the installer directly from the command line, so we can maybe see if an error message appears there?

       

      thanks,

      Chris Bailey

        • 1. Re: Filemaker Server 15 installation won't get started
          planteg

          Hi Chris,

           

          did you have a look at Windows logs ? You may get hint in there as to what's going wrong.

          • 2. Re: Filemaker Server 15 installation won't get started
            wimdecorte

            There is also a deployment log, it may be in the temp folder.

             

            After uninstalling FMS14, did you delete or rename the "filemaker server" folder that was left in the 'program files' area?

            If not then FMS15 may pick up on some of the old config files and fail to install or run properly.

            • 3. Re: Filemaker Server 15 installation won't get started
              stevecarter

              Did you find the answer to this?  I have the same problem.  Microsoft Server 2008 R2 had a working FileMaker Server 14.  FileMaker 15 fails to install.  It will run the extractor part of the installation but after it extracts all the files it fails to run the setup.exe.  If I run the setup.exe it does nothing.  I've tried running the compatibility assistant and it doesn't run, period.  I've tried the runas.exe with different options and nothing. 

               

              I've even tried installing the FileMaker Server 14 and it does nothing.

               

              I don't know what to do from here.  Help.

              • 4. Re: Filemaker Server 15 installation won't get started
                user10625

                No, I tried Wim's suggestion (delete the FMS folder) , and I also noticed that my Java was out of date, so I updated that, and still no dice.  

                 

                I have a feeling that the only solution is to totally re-install Windows, so the machine is completely 'vanilla',  but that's going to annoy the @#$% out of the IT manager, he'll say "but it IS vanilla, we've done NOTHING to it, no virus scanners, no extra software, nothing..."  And he's right, but,  ....I don't know what else to do at this point.

                 

                The only thing we've done that's non-vanilla is to install Mirrorsync (360works product) on the box, I can't imagine that would hold things up.   (It didn't prevent 14 from installing.)

                 

                Let me know if you discover anything useful.

                • 5. Re: Filemaker Server 15 installation won't get started
                  wimdecorte

                  stevecarter wrote:

                   

                  I've even tried installing the FileMaker Server 14 and it does nothing.

                   

                   

                  This points to the fact that it is not FMS15 or its installer but clearly something on the machine.  They don't need to reinstall from scratch, are there no snapshots or restore points?

                   

                  What does the Windows system or application log say about the attempts to run the installers?  There must be some clue somewhere, these things almost never fail without saying why.

                   

                  Make sure to reboot after a failed install attempt.

                  • 6. Re: Filemaker Server 15 installation won't get started
                    user10625

                    Before the thing fails, I notice the command line window pops up and all kinds of things happen very quickly, then it disappears.  I've been thinking that a transcript of what happens there might be useful.  Is there any software that would capture that?

                    • 7. Re: Filemaker Server 15 installation won't get started
                      wimdecorte

                      There is a deployment log that gets created somewhere so look for that.  Also see what the windows logs have to say.

                      • 8. Re: Filemaker Server 15 installation won't get started
                        user10625

                        As far as I remember (but I will try again),  neither of those options works.  The failure happens before the deployment log gets written to  (i.e.,  the log's mod date is not today, but months ago when I last did an installation.)    And I don't think the windows logs helped us either.  But we will try again to be sure.

                        • 9. Re: Filemaker Server 15 installation won't get started
                          tcfitzgerald

                          I've had issues like this with FileMaker Server 13 and 14.

                           

                          I solved it by making sure my installer files were on the C: drive.  For some reason FileMaker Server install would not run from E:.  Are your installers on a drive other than C:?

                           

                          I also make it a point to right-click and choose "Run As Administrator..." even if I am logged in with an account that has admin rights.

                          • 10. Re: Filemaker Server 15 installation won't get started
                            user10625

                            tcfitzgerald wrote:

                             

                            I've had issues like this with FileMaker Server 13 and 14.

                             

                             

                            I solved it by making sure my installer files were on the C: drive. For some reason FileMaker Server install would not run from E:. Are your installers on a drive other than C:?

                             

                            I also make it a point to right-click and choose "Run As Administrator..." even if I am logged in with an account that has admin rights.

                             

                            I saw the issue with 14.  In that case, the solution was to unplug the network cable for the installation, for some reason when the installation was able to "phone home" ( or phone somewhere ), it failed.  Now, it seems to need an internet connection to succeed, so that idea's out the window.

                             

                            I'm pretty sure my installers are on the C: drive.  I also tried putting them directly into the Program Files folder, or something like that that I saw on another thread.   And I've also done Run As Administrator as well.

                            • 11. Re: Filemaker Server 15 installation won't get started
                              stevecarter

                              So here's how I solved it.  I was logged in as the domain administrator account.  Which I didn't think was a problem.  Stressed and tired I went home.  Later in the morning I remotely logged in under my account which is also a domain admin.  And the setup worked.  It was as if there was some sort of block on programs called setup.exe

                               

                              So everything installed perfectly under my account and everything was good this morning when the rest of the employees came in.

                               

                              Thanks for everyone's help and input.

                              • 12. Re: Filemaker Server 15 installation won't get started
                                user10625

                                OK, I finally got it to work.  I was clued in by SteveCarter's comment that " It was as if there was some sort of block on programs called setup.exe". 

                                 

                                 

                                 

                                So, I ran the installer package as normal, and it unpacked "Filemaker server 15" folder.

                                 

                                 

                                Then in order to complete the installation, I had to go into Filemaker Server 15/Files/ and run Setup.exe in there, with admin privileges.  Then it seemed to work.

                                 

                                 

                                We did this on a test server (a virtual copy of the one we'll be installing on for real).

                                 

                                 

                                My question is (for Wim Decorte or whatever other luminaries are listening in)  . . .before I do it for real . . . does this method seem dangerous at all?  Everything seemed to run perfectly normally, and I set everything up on the Admin Console when it was done, etc.  So I think it's fine . . but it is odd that I had to go in there and run that file directly.

                                 

                                 

                                (Also, is this a bug that should be reported?)