AnsweredAssumed Answered

crashing when inserting containers

Question asked by gethappy@happypc.com on Nov 14, 2016
Latest reply on Nov 14, 2016 by user19752

Having a problem that we have been trying to troubleshoot for months with no success.

 

Basically we have a database that is used to catalog pictures and movie files.  We upload a file (mp4, pdf, jpg) and it intermittently crashes during the upload process.   The files can be as large as 250MB, but many times are only a few MB in size. 

 

We use two fields to insert images ...

 

first the user drops a file onto a container (not external) field and a field script trigger is activated (onSave).  We call this field "CONTAINERTEMP"

 

the script trigger then uses a SET FIELD to insert this image into the real container field which is an open external container field.  We call this field just "IMAGECONTAINER".  The external container 'location' is physical located on the FMP server inside the DATA directory of the FileMaker Pro Server directory.  It is a single fold which is fairly large ... roughly 500GB.

 

We don't allow the users to directly insert images into IMAGECONTAINER, because if a file with the same name already exists it will override (erase) the original file with the newly inserted file.  Instead we SET FIELD IMAGECONTAINER to be CONTAINERTEMP and error trap for error 504.  if the error is found, we stop the script and display an error to the user so they can rename the new file and try again, otherwise the file gets externally stored into IMAGECONTAINER, then we clear (using set field) to the CONTAINERTEMP field at the end.

 

Most times this process works great, but maybe every 10th time (especially with large files) it crashes THE SERVER and ALL users get a spinning ball until we reboot the server.  We can't close the database or disconnect users on the server, only a reboot solves the issue.

 

We notice when multiple users are inserting at the same time this can exasperate the issue, but many times it happens with only one user inserting as well.  The problem seems to happen more with Mac users, but this could be because the mac users are usually inserting large mp4 files while the windows users are usually only inserting small files.

 

We have tried many different options, but never can get the problem solved ... including ...

using Filemaker 14 was a problem, using 15.02 is still a problem.

making the CONTAINERTEMP a global field vs. non global.

making the CONTAINERTEMP an externally stored container

using PSOS to do the "set field" work

multiple physical hardware servers to see if it was a hardware situation.

 

any suggestions?  I'm beginning to think maybe it is a networking issue OR FMP is just not able to handle large files that are external. (which I have a hard time believing)??

Outcomes