5 Replies Latest reply on Nov 15, 2016 12:44 PM by fmpdude

    Java 8 .111 problems

    abonino

      Hi

      i can't install FMS15.02 on a MacBookPro 17" 2011 early:

       

      - New SSD Evo 840 1TB (worked with 10.10 ...) with new installation 10.11.5

      - restored from backup, multible tests (clean start)

      - FW OFF

      - Gatekeeper: any Apps

      - LittleSnitch NO

      - new DNS 8888, 4444, ...

      - Launchd-integration break?

       

      + FMS Installer 15.02

      + Java Upd 8.111 stand-alone

       

      >> log-file and pict

       

      what can i do?

      have everyone a FMS15-Installation with this device?

       

      regards, Arthur

        • 1. Re: Java 8 .111 problems
          wimdecorte

          java 8u101 is the supported version for FMS15v2:

           

          FileMaker Server and Java - Overview | FileMaker

           

          From your screenshot it looks like it is that required version of java that fails to install, not so much FMS.  Remove all java versions from that box, reboot and try the installer again.

          • 2. Re: Java 8 .111 problems
            fmpdude

            Yep, Wim is right. Check your computer logs. See why it failed. I've never had a Java install fail on the Mac. This isn't an FMP issue. And, Java is extremely well supported on both Windows, and (thank you, Oracle), on the Mac.

             

            I believe the JDK is signed so GateKeeper shouldn't be upset about (GateKeeper is more strict staring in Sierra, 10.12) and would stop the install at the beginning not a crash in the middle, but you can always disable GateKeeper (Google for that).

             

            I use Java on the Mac so if I can help, I'll be glad to.

             

            If you need to find the JDK, assuming that's what you installed, and not just the JRE, to delete what might have gotten installed, look here:

             

            /Library/Java/JavaVirtualMachines/

             

            HOPE THIS HELPS.

            • 3. Re: Java 8 .111 problems
              fmpdude

              FWIW, I just upgraded my Java JDK on my Mac after reading your post. I upgraded from JDK 101 to JDK 111 as you can see from the screenshot below.

               

              I didn't find any issues.

               

              Maybe you should try to upgrade your OS to Sierra as one possible thing to try?

               

              For me, the only issue I ran into upgrading to Sierra was MySQL, which hung with 5.7.11. I had to upgrade to version 5.7.16 (free, of course) and migrate my data. There were a couple other issues like the ScanSnap scanner, but those have all since been patched.

               

              I had zero issues with FMP 14 with Sierra.

               

              HOPE THIS HELPS.

              • 4. Re: Java 8 .111 problems
                abonino

                Now its work!

                 

                The first installation was made with a USB-Stick-Installer 10.11.3 and updates.

                 

                The first FMS-Installation was 15.02 with java 101 and interrupt. Then i download Java 8.111 (only this i found) and try: same interrupt.

                - No files on /Library/Java/JavaVirtualMachines/

                 

                Now complete new installation with starting on recovery-partition, delete partition, install 10.11.5, AppStore and macOS 10.12.1 directly.

                - FW ON

                - Gatekeeper: default (nothing change)

                - 1 Admin-Account, used directly

                 

                ;))))))))

                • 5. Re: Java 8 .111 problems
                  fmpdude

                  If there are no files at that directory, then you're just installing the JRE.

                   

                  Glad you got it working.