4 Replies Latest reply on Nov 17, 2016 4:25 PM by beelics

    Accessing a Filemaker Server behind a Firewall in China

    beelics

      Hi, I am having an issue accessing a filemaker server I setup in China behind a factory firewall.

       

      The server was setup on a Mac that has a dual ethernet card so it exists on two networks. One network is accessible from inside my company VPN and the other is accessible to the Chinese factory. When the server was first setup, the mac was giving me an error about using ports 80 & 443 so I changed them to 81 & 444 just to install the server software. I then went into the config files and changed the Listen port from 81 -> 80 & 444 -> 443 on:

      /Library/Filemaker server/HTTPServer/conf/httpd.conf

      /Library/Filemaker server/HTTPServer/conf/extra/httpd-ssl.conf

       

      Initially, the admin console showed that web publishing engine was green but the web server was grey. The admin console worked (I could access from US and also from the localhost) for a while after the server was setup but does not work anymore (I receive an error when attempting to access the admin console). I was never able to access web direct even thought it is turned on, even when I screenshare into the computer and try to access web direct through localhost it gives me an error that says Apache is using port 80. I turned Apache off and this issue is still showing up.

       

      Can anybody help me access web direct and admin console from my US location? I am unsure what has changed on the server, and how to overcome the access with connecting to Webdirect.

       

      When I setup filemaker server in the US and turned on web direct, it worked instantly, so I am assuming there is some issue with the firewall or dual ethernet connection that I am missing.

       

      Thanks