2 Replies Latest reply on Nov 16, 2016 6:07 PM by LawrenceCamp

    FM 15 on Terminal Server - poor performance

    LawrenceCamp

      On a new installation of FileMaker Pro 15.0.2.220 on Windows Server 2008 R2 Standard with Service Pack 1, the Launch Center takes 2 to 3 minutes to find the hosted files. The message is “Waiting for response…” with a progress bar.

       

      Once the file is found and clicked to open the hourglass is present for 2 to 3 minutes before the password dialog opens. Once the user name and password are entered FileMaker says Not Responding for 4 to 5 minutes before the solution finally opens.

       

      Once the solution opens it functions normally. FM 14.0.6 on the same machine opens the files quickly - no delays and the solution functions normally.

       

      The files are hosted by FMS 15.0.2.206 on Windows Server 2008 R2 Standard with Service Pack 1. Both both servers are virtual machines running on the same box with Intel® Xeon® CPU E5-2440 v2 @ 1.90GHz (2 processors)

       

      Any ideas on how to resolve this issue?

       

      Many thanks,

      Lawrence

      -

      Lawrence B. Camp

      LB Camp Consulting, LLC

      FileMaker 7, 8, 9, 10, 11, 12, 13, 14, 15 Certified Developer

      l@lbcamp.com

        • 1. Re: FM 15 on Terminal Server - poor performance
          CICT

          Lawrence, your timing is very interesting, as I spent an hour on the phone with a fellow developer yesterday complaining about the same thing. In his case he is running FileMaker Licensing for Teams, which is performing very slow compared to his copy of FileMaker 15 Advanced running on the same terminal server and his own development TS.

           

          The solution he is considering is to request to change his licensing from FLT to a standard AVLA. Are you running licensing for teams or a standard VLA/AVLA?

           

          He has a few tests to finish, such as running a copy of FLT FM Pro on the same account he's using Advanced on, but at the moment his assumption is that FLT is the problem. I've been through DNS and possible routing issues, but he insists his network is very straightforward.

           

          We're running AVLA licenses on 6 different RDS servers without any problems, albeit streaming via Citrix and RemoteApp.

           

          We'd love to hear from anyone running licensing for teams on a Terminal Server/Remote Desktop Server who is not having any speed issues.

           

          Lawrence, on your particular problem, are you sure you don't have a network setup where network traffic could be escaping over the Internet that would result in latency?

           

           

          Regards

          Andy

          • 2. Re: FM 15 on Terminal Server - poor performance
            LawrenceCamp

            Andy,

             

            My client has an FLT license, but I also have FM 15 Advanced on the same machine and it runs just as slow as FM Pro. I’ve other clients running FM 15 via terminal services but they’re also using either Citrix or Parallel Application Server.

             

            FLT license for FM 14 runs fine on the same machine connecting to FMS 15.

             

            Please do let me know how your fellow developer’s idea for changing licensing workout.

             

            Thanks so much for your response,

            Lawrence